summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2019-02-09 16:18:00 +0000
committerGrey Christoforo2019-02-09 16:18:00 +0000
commit6ff01caa349100c43a513e51a57321461d878fe6 (patch)
treeeed198ea8880bcf7e1bbc9400df0cb0bb3eeb9fe
downloadaur-6ff01caa349100c43a513e51a57321461d878fe6.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3fa4b1b09c54
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-q2-types
+ pkgdesc = Definitions of common QIIME 2 types.
+ pkgver = 2019.1.0
+ pkgrel = 1
+ url = https://qiime2.org
+ arch = any
+ license = BSD 3-Clause License
+ makedepends = python-setuptools
+ depends = python
+ depends = python-qiime2
+ depends = python-biom-format
+ depends = python-scikit-bio
+ depends = python-h5py
+ depends = python-pandas
+ depends = python-ijson
+ source = https://github.com/qiime2/q2-types/archive/2019.1.0.tar.gz
+ sha256sums = facb098fb05f9833417de2dccf108675619d480c0efdac6545a384c6473ff460
+
+pkgname = python-q2-types
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..574a8578368c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src
+/pkg
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8551638828b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
+
+pkgname=python-q2-types
+_pkgname=q2-types
+pkgver=2019.1.0
+pkgrel=1
+pkgdesc="Definitions of common QIIME 2 types."
+arch=('any')
+url="https://qiime2.org"
+license=('BSD 3-Clause License')
+depends=('python' 'python-qiime2' 'python-biom-format' 'python-scikit-bio' 'python-h5py' 'python-pandas' 'python-ijson')
+makedepends=('python-setuptools')
+source=("https://github.com/qiime2/${_pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('facb098fb05f9833417de2dccf108675619d480c0efdac6545a384c6473ff460')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
+}
+
+
+package(){
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:ts=2:sw=2:et: