summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarvin Delgado2023-06-19 23:56:05 -0400
committerDarvin Delgado2023-06-19 23:56:05 -0400
commit7046ae17dcbb932498880cebde3d1ffa8442f279 (patch)
tree02add835d893ed8b24744e3ec09901cccaec7655
parent1b54ba64d9da983b5166843ae2153cb878ccb2f8 (diff)
downloadaur-7046ae17dcbb932498880cebde3d1ffa8442f279.tar.gz
add mangoapp
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD32
2 files changed, 32 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51d6e9f471a9..36219f434318 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,38 @@
pkgbase = mangohud-git
pkgdesc = A Vulkan overlay layer for monitoring FPS, temperatures, CPU/GPU load and more.
- pkgver = 0.6.8.r145.g020e848
+ pkgver = 0.6.9.1.r79.g30748bd
pkgrel = 1
url = https://github.com/flightlessmango/MangoHud
arch = x86_64
license = MIT
makedepends = git
+ makedepends = appstream
+ makedepends = cmocka
+ makedepends = glfw-x11
makedepends = glslang
- makedepends = libx11
makedepends = libxnvctrl
makedepends = meson
+ makedepends = nlohmann-json
makedepends = python-mako
- makedepends = vulkan-headers
depends = dbus
+ depends = fmt
+ depends = gcc-libs
+ depends = glew
depends = hicolor-icon-theme
+ depends = libglvnd
+ depends = libx11
+ depends = python-matplotlib
+ depends = python-numpy
+ depends = spdlog
depends = vulkan-icd-loader
- optdepends = libxnvctrl: NVIDIA GPU stats
- optdepends = lib32-mangohud-git: 32-bit support
+ optdepends = libxnvctrl: NVIDIA GPU stats by XNVCtrl
+ optdepends = glfw-x11: Required for MangoApp
+ optdepends = gamescope: Use MangoApp as an overlay within gamescope
provides = mangohud
- provides = mangohud-common
+ provides = mangoapp
conflicts = mangohud
- conflicts = mangohud-common
+ conflicts = mangoapp
conflicts = mangohud-common-git
- replaces = mangohud-common-git
source = mangohud-git::git+https://github.com/flightlessmango/MangoHud
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 42ab7ae21863..cdc0e3eb8436 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,19 @@
# Maintainer: Darvin Delgado <dnmodder at gmail dot com>
pkgname=mangohud-git
-pkgver=0.6.8.r145.g020e848
+pkgver=0.6.9.1.r79.g30748bd
pkgrel=1
pkgdesc="A Vulkan overlay layer for monitoring FPS, temperatures, CPU/GPU load and more."
url='https://github.com/flightlessmango/MangoHud'
license=('MIT')
arch=('x86_64')
-makedepends=('git' 'glslang' 'libx11' 'libxnvctrl' 'meson' 'python-mako' 'vulkan-headers')
-depends=('dbus' 'hicolor-icon-theme' 'vulkan-icd-loader')
-optdepends=(
- 'libxnvctrl: NVIDIA GPU stats'
- 'lib32-mangohud-git: 32-bit support'
-)
-provides=('mangohud' 'mangohud-common')
-conflicts=('mangohud' 'mangohud-common' 'mangohud-common-git')
-replaces=('mangohud-common-git')
+makedepends=('git' 'appstream' 'cmocka' 'glfw-x11' 'glslang' 'libxnvctrl' 'meson' 'nlohmann-json' 'python-mako')
+depends=('dbus' 'fmt' 'gcc-libs' 'glew' 'hicolor-icon-theme' 'libglvnd' 'libx11' 'python-matplotlib' 'python-numpy' 'spdlog' 'vulkan-icd-loader')
+optdepends=('libxnvctrl: NVIDIA GPU stats by XNVCtrl'
+ 'glfw-x11: Required for MangoApp'
+ 'gamescope: Use MangoApp as an overlay within gamescope')
+provides=('mangohud' 'mangoapp')
+conflicts=('mangohud' 'mangoapp' 'mangohud-common-git')
source=("$pkgname::git+$url")
sha512sums=('SKIP')
@@ -27,20 +25,18 @@ pkgver() {
build() {
local meson_options=(
--wrap-mode=forcefallback
- -Dtests=disabled
+ -Dmangoapp=true
+ -Dmangohudctl=true
+ -Dmangoapp_layer=true
$pkgname
)
arch-meson "${meson_options[@]}" build
- ninja -C build
+ meson compile -C build
}
package() {
- meson install --destdir="$pkgdir" -C build
+ meson install -C build --destdir "$pkgdir"
- if [ -f "$pkgdir/usr/lib/libMangoHud.so" ]; then
- mv "$pkgdir/usr/lib/libMangoHud.so" "$pkgdir/usr/lib/mangohud/"
- fi
-
- install -Dm664 "$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm 0664 "$pkgname/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
}