summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorsten Keßler2022-04-10 12:13:18 +0200
committerTorsten Keßler2022-04-10 12:13:18 +0200
commit704f6d968c62e54e6267e56d00005af2117c129e (patch)
treec8b3925cb505d6f6a576148819683b582ac6126d
parentd546def8b25b58e4dbb1ae67514c4e33ff48de5c (diff)
downloadaur-704f6d968c62e54e6267e56d00005af2117c129e.tar.gz
upgpkg: hipblas 5.1.1-1
upstream release
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 123bc84fe4de..cdf99b426c0b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = hipblas
pkgdesc = ROCm BLAS marshalling library
- pkgver = 5.1.0
+ pkgver = 5.1.1
pkgrel = 1
url = https://rocmdocs.amd.com/en/latest/ROCm_Libraries/ROCm_Libraries.html#hipblas
arch = x86_64
@@ -10,7 +10,7 @@ pkgbase = hipblas
depends = hip
depends = rocblas
depends = rocsolver
- source = hipblas-5.1.0.tar.gz::https://github.com/ROCmSoftwarePlatform/hipBLAS/archive/rocm-5.1.0.tar.gz
- sha256sums = 22faba3828e50a4c4e22f569a7d6441c797a11db1d472619c01d3515a3275e92
+ source = hipblas-5.1.1.tar.gz::https://github.com/ROCmSoftwarePlatform/hipBLAS/archive/rocm-5.1.1.tar.gz
+ sha256sums = 28a3dae441f04d2e7f7b0f650ddd086f4f20c1ec082e7dd23ab3083e6736d473
pkgname = hipblas
diff --git a/PKGBUILD b/PKGBUILD
index 3eb70c92b229..0e2615c05f29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Torsten Keßler <t dot kessler at posteo dot de>
# Contributor: Markus Näther <naether.markus@gmail.com>
pkgname=hipblas
-pkgver=5.1.0
+pkgver=5.1.1
pkgrel=1
pkgdesc='ROCm BLAS marshalling library'
arch=('x86_64')
@@ -11,12 +11,12 @@ depends=('hip' 'rocblas' 'rocsolver')
makedepends=('cmake' 'gcc-fortran')
_git='https://github.com/ROCmSoftwarePlatform/hipBLAS'
source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz")
-sha256sums=('22faba3828e50a4c4e22f569a7d6441c797a11db1d472619c01d3515a3275e92')
+sha256sums=('28a3dae441f04d2e7f7b0f650ddd086f4f20c1ec082e7dd23ab3083e6736d473')
_dirname="$(basename "$_git")-$(basename "${source[0]}" ".tar.gz")"
build() {
# -fcf-protection is not supported by HIP, see
- # https://github.com/ROCm-Developer-Tools/HIP/blob/rocm-4.5.x/docs/markdown/clang_options.md
+ # https://github.com/ROCm-Developer-Tools/HIP/blob/rocm-5.1.x/docs/markdown/clang_options.md
CXX=/opt/rocm/bin/hipcc \
CXXFLAGS="${CXXFLAGS} -fcf-protection=none" \
cmake -B build -Wno-dev \