summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOleg Shparber2020-09-10 18:28:40 -0400
committerOleg Shparber2020-09-10 18:28:40 -0400
commit7057e3b30b9d3842d37ce384c0edbee9e16c58fd (patch)
tree4b28a4426f52f50927cdad34ba624dd07b6fa339
parent52ac30149243e217de1facdbf7c9947701af2f80 (diff)
downloadaur-7057e3b30b9d3842d37ce384c0edbee9e16c58fd.tar.gz
Compile static OTF fonts due to a bug in psautohint
See https://github.com/adobe-type-tools/psautohint/issues/40
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 060c1e26e76e..d257ca93ef18 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cascadia-code-git
pkgdesc = A new monospaced font that includes programming ligatures
pkgver = 2008.25.r1.gc6492c66
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/microsoft/cascadia-code
arch = any
license = custom:OFL
diff --git a/PKGBUILD b/PKGBUILD
index dc69094f98df..a5b4064c28cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _gitname=cascadia-code
pkgbase=cascadia-code-git
pkgname=("otf-${pkgbase}" "ttf-${pkgbase}")
pkgver=2008.25.r1.gc6492c66
-pkgrel=1
+pkgrel=2
pkgdesc="A new monospaced font that includes programming ligatures"
url="https://github.com/microsoft/${_gitname}"
arch=('any')
@@ -26,12 +26,12 @@ build() {
python -m venv .venv
source .venv/bin/activate
pip install -r requirements.txt
- python build.py
+ python build.py -S
}
package_otf-cascadia-code-git() {
cd "${_gitname}"
- install -Dm644 build/*.otf -t "$pkgdir"/usr/share/fonts/OTF
+ install -Dm644 build/static/*.otf -t "$pkgdir"/usr/share/fonts/OTF
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}