summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTest User2020-02-10 08:34:04 -0700
committerTest User2020-02-10 08:34:04 -0700
commit7062f3f6555c75cf34caea99f18fcb627a100ab9 (patch)
tree53f6d2fb764b61440ce809639423e19ec8c0d5c8
parentd6929e31e547e02d0182e9bfca60550ed51c1230 (diff)
downloadaur-7062f3f6555c75cf34caea99f18fcb627a100ab9.tar.gz
updated to 2020.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD26
-rwxr-xr-xupdate-relays.sh35
3 files changed, 46 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ec8d1f0f72a..f4e691ce4163 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,25 @@
pkgbase = mullvad-vpn
pkgdesc = The Mullvad VPN client app for desktop
- pkgver = 2019.10
- pkgrel = 2
+ pkgver = 2020.1
+ pkgrel = 1
url = https://www.mullvad.net
install = mullvad-vpn.install
arch = x86_64
license = GPL3
makedepends = git
- makedepends = cargo
+ makedepends = go-pie
+ makedepends = rust
makedepends = npm
depends = libnotify
depends = libappindicator-gtk3
depends = libxss
depends = nss
- source = git+https://github.com/mullvad/mullvadvpn-app.git#tag=2019.10?signed
- source = git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=0c1a0aca41492fbb9ef1f187122e2f5bda0927ba?signed
+ source = git+https://github.com/mullvad/mullvadvpn-app.git#tag=2020.1?signed
+ source = git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=90b0c06b59a0b9d6cda69924377335f39854b216?signed
source = mullvad-vpn.desktop
source = update-relays.sh
validpgpkeys = EA0A77BF9E115615FC3BD8BC7653B940E494FE87
+ validpgpkeys = 8339C7D2942EB854E3F27CE5AEE9DECFD582E984
sha256sums = SKIP
sha256sums = SKIP
sha256sums = 121d90e6683e64d9c0d2dbb7b346fa918bdb37cf21fdaf9f66232304ed23abc2
diff --git a/PKGBUILD b/PKGBUILD
index 32cd508e728f..0a4d20ef9ea9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,16 +7,16 @@
# Contributor: Emīls Piņķis <emil at mullvad dot net>
# Contributor: Andrej Mihajlov <and at mullvad dot net>
pkgname=mullvad-vpn
-pkgver=2019.10
-pkgrel=2
+pkgver=2020.1
+pkgrel=1
pkgdesc="The Mullvad VPN client app for desktop"
url="https://www.mullvad.net"
arch=('x86_64')
license=('GPL3')
depends=('libnotify' 'libappindicator-gtk3' 'libxss' 'nss')
-makedepends=('git' 'cargo' 'npm')
+makedepends=('git' 'go-pie' 'rust' 'npm')
install="$pkgname.install"
-_commit='0c1a0aca41492fbb9ef1f187122e2f5bda0927ba'
+_commit='90b0c06b59a0b9d6cda69924377335f39854b216'
source=("git+https://github.com/mullvad/mullvadvpn-app.git#tag=$pkgver?signed"
"git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=$_commit?signed"
"$pkgname.desktop"
@@ -25,8 +25,10 @@ sha256sums=('SKIP'
'SKIP'
'121d90e6683e64d9c0d2dbb7b346fa918bdb37cf21fdaf9f66232304ed23abc2'
'ec125bc9cfe2403bacfcaebf4b58f88b4d734b0f6194c23016efd7e15684f8e0')
-validpgpkeys=('EA0A77BF9E115615FC3BD8BC7653B940E494FE87')
+validpgpkeys=('EA0A77BF9E115615FC3BD8BC7653B940E494FE87'
# Linus Färnstrand (code signing key) <linus at mullvad dot net>
+ '8339C7D2942EB854E3F27CE5AEE9DECFD582E984')
+ # David Lönnhager (code signing) <david dot l at mullvad dot net>
prepare() {
# Point the submodule to our local copy
@@ -41,13 +43,25 @@ prepare() {
}
build() {
+ cd "$srcdir/mullvadvpn-app/wireguard/wireguard-go"
+
+ # Build wireguard-go
+ go build \
+ -trimpath \
+ -ldflags "-extldflags $LDFLAGS" \
+ -v -o libwg.a -buildmode c-archive
+
+ target_triple_dir="../../build/lib/x86_64-unknown-linux-gnu"
+ mkdir -p $target_triple_dir
+ cp libwg.a $target_triple_dir
+
cd "$srcdir/mullvadvpn-app"
# Remove old Rust build artifacts
cargo clean --release --locked
# Build mullvad-daemon
- cargo build --release --locked
+ cargo build --release --locked --all-features
# Copy binaries for packaging
cp dist-assets/binaries/x86_64-unknown-linux-gnu/{openvpn,sslocal} \
diff --git a/update-relays.sh b/update-relays.sh
index ef63dcd6afbf..88f43c3ca60b 100755
--- a/update-relays.sh
+++ b/update-relays.sh
@@ -1,19 +1,22 @@
#!/bin/bash
+echo "Updating relay list..."
+set +e
read -d '' JSONRPC_CODE <<-JSONRPC_CODE
- var buff = "";
- process.stdin.on('data', function (chunk) {
- buff += chunk;
- })
- process.stdin.on('end', function () {
- var obj = JSON.parse(buff);
- var output = JSON.stringify(obj.result, null, ' ');
- process.stdout.write(output);
- })
- JSONRPC_CODE
+var buff = "";
+process.stdin.on('data', function (chunk) {
+ buff += chunk;
+})
+process.stdin.on('end', function () {
+ var obj = JSON.parse(buff);
+ var output = JSON.stringify(obj.result, null, ' ');
+ process.stdout.write(output);
+})
+JSONRPC_CODE
+set -e
- JSONRPC_RESPONSE="$(curl -X POST \
- --fail \
- -H "Content-Type: application/json" \
- -d '{"jsonrpc": "2.0", "id": "0", "method": "relay_list_v3"}' \
- https://api.mullvad.net/rpc/)"
- echo "$JSONRPC_RESPONSE" | node -e "$JSONRPC_CODE" > dist-assets/relays.json
+JSONRPC_RESPONSE="$(curl -X POST \
+ --fail \
+ -H "Content-Type: application/json" \
+ -d '{"jsonrpc": "2.0", "id": "0", "method": "relay_list_v3"}' \
+ https://api.mullvad.net/rpc/)"
+echo $JSONRPC_RESPONSE | node -e "$JSONRPC_CODE" > dist-assets/relays.json