summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Bouvier2020-06-18 17:38:06 +0200
committerAlexandre Bouvier2020-06-18 17:38:06 +0200
commit7068d4a8a7aa708e26936325d5720fddc7f443ba (patch)
tree8fc2cd8da831363cebe273d2332c4813894c740e
parentb85af4551ded8fd9336863f4c60094ece5b2f1c5 (diff)
downloadaur-7068d4a8a7aa708e26936325d5720fddc7f443ba.tar.gz
Raising of Lazarus
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD53
-rw-r--r--noto-fonts-emoji.install11
-rw-r--r--noto-fonts-emoji.patch13
4 files changed, 37 insertions, 71 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8aca761afc3..f4ff871a8c50 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,22 @@
-# Generated by mksrcinfo v8
-# Sun Dec 27 19:11:01 UTC 2015
pkgbase = noto-fonts-emoji-git
- pkgdesc = Google Noto emoji fonts
- pkgver = r81.9417128
- pkgrel = 3
- url = https://www.google.com/get/noto/
- install = noto-fonts-emoji.install
+ pkgdesc = Noto Emoji fonts
+ pkgver = 2020.04.08.unicode12_1.r23.g8990ed0f
+ pkgrel = 1
+ epoch = 1
+ url = https://github.com/googlefonts/noto-emoji
arch = any
license = Apache
- makedepends = cairo
makedepends = git
- makedepends = optipng
- makedepends = python2-fonttools
- makedepends = python2-setuptools
- makedepends = nototools
- makedepends = zopflipng-git
- depends = fontconfig
+ makedepends = zopfli
+ makedepends = python-fonttools
+ makedepends = python-nototools
+ makedepends = pngquant
+ makedepends = cairo
+ makedepends = imagemagick
provides = noto-fonts-emoji
conflicts = noto-fonts-emoji
- source = noto-fonts-emoji::git+https://github.com/googlei18n/noto-emoji.git
- source = noto-fonts-emoji.patch
- sha512sums = SKIP
- sha512sums = 72f3c82ba3a1e69c158c3238c4c817df3e77302071ec1094fb284863ee72fb00117d89531ba75412501507984df4561ad013a09ac5742728c240bf073d80f4d0
+ source = noto-fonts-emoji::git+https://github.com/googlefonts/noto-emoji.git
+ md5sums = SKIP
pkgname = noto-fonts-emoji-git
diff --git a/PKGBUILD b/PKGBUILD
index b3f8429ecb6d..9c4117df2b81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,39 @@
-# $Id: PKGBUILD 249884 2015-10-30 21:49:02Z arojas $
-# Maintainer: Antonio Rojas <arojas@archlinux.org>
+# Maintainer: Alexandre Bouvier <contact@amb.tf>
+# Contributor: Antonio Rojas <arojas@archlinux.org>
# Contributor: Claire Charron <claire@undeterminant.net>
-
+# shellcheck shell=bash disable=SC2034,SC2164
_pkgname=noto-fonts-emoji
pkgname=$_pkgname-git
-pkgver=r81.9417128
-pkgrel=3
-pkgdesc="Google Noto emoji fonts"
-arch=(any)
-url="https://www.google.com/get/noto/"
-license=(Apache)
-provides=($_pkgname)
-conflicts=($_pkgname)
-depends=(fontconfig)
-makedepends=(cairo git optipng python2-fonttools python2-setuptools nototools zopflipng-git)
-install=$_pkgname.install
-source=("$_pkgname::git+https://github.com/googlei18n/noto-emoji.git"
- "$_pkgname.patch")
-sha512sums=('SKIP'
- '72f3c82ba3a1e69c158c3238c4c817df3e77302071ec1094fb284863ee72fb00117d89531ba75412501507984df4561ad013a09ac5742728c240bf073d80f4d0')
+pkgver=2020.04.08.unicode12_1.r23.g8990ed0f
+pkgrel=1
+epoch=1
+pkgdesc="Noto Emoji fonts"
+arch=('any')
+url="https://github.com/googlefonts/noto-emoji"
+license=('Apache')
+makedepends=('git' 'zopfli' 'python-fonttools' 'python-nototools' 'pngquant' 'cairo' 'imagemagick')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_pkgname::git+$url.git")
+md5sums=('SKIP')
pkgver() {
- cd "$_pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd $_pkgname
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "$_pkgname"
- patch -i ../$_pkgname.patch
- find -name '*.py' | xargs sed -e 's|/usr/bin/env python|/usr/bin/env python2|' -i
- sed -e 's|python|python2|g' -e 's|ttx "$<"|ttx2 "$<"|g' -i Makefile
+ cd $_pkgname
+ make clean
}
build() {
- cd "$_pkgname"
- make
+ cd $_pkgname
+ make VIRTUAL_ENV=dummy
}
package() {
- cd "$_pkgname"
- mkdir -p "$pkgdir"/usr/share/fonts/noto
- install -m644 NotoColorEmoji.ttf fonts/NotoEmoji-Regular.ttf "$pkgdir"/usr/share/fonts/noto
+ cd $_pkgname
+ # shellcheck disable=SC2154
+ install -Dm644 -t "$pkgdir"/usr/share/fonts/noto NotoColorEmoji.ttf
}
diff --git a/noto-fonts-emoji.install b/noto-fonts-emoji.install
deleted file mode 100644
index ac6cb5b6f4ac..000000000000
--- a/noto-fonts-emoji.install
+++ /dev/null
@@ -1,11 +0,0 @@
-post_install() {
- fc-cache -s
-}
-
-post_upgrade() {
- post_install $1
-}
-
-post_remove() {
- post_install $1
-}
diff --git a/noto-fonts-emoji.patch b/noto-fonts-emoji.patch
deleted file mode 100644
index 30dbe0ff9b16..000000000000
--- a/noto-fonts-emoji.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/Makefile b/Makefile
-index 324165e..812979f 100644
---- a/Makefile
-+++ b/Makefile
-@@ -71,7 +71,7 @@ SELECTED_FLAGS = AD AE AF AG AI AL AM AO AR AS AT AU AW AX AZ \
- ZA ZM ZW
- ALL_FLAGS = $(basename $(notdir $(wildcard $(FLAGS_SRC_DIR)/*.png)))
-
--FLAGS = $(SELECTED_FLAGS)
-+FLAGS = $(ALL_FLAGS)
-
- FLAG_NAMES = $(FLAGS:%=%.png)
- FLAG_FILES = $(addprefix $(FLAGS_DIR)/, $(FLAG_NAMES))