summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Vihrov2016-06-12 19:17:08 +0300
committerAndrey Vihrov2016-06-12 19:17:08 +0300
commit70b474c6418e726cfbcced8fa08f8850e661ef12 (patch)
tree331481768b5abbc850d0da9842783f0c18864451
downloadaur-70b474c6418e726cfbcced8fa08f8850e661ef12.tar.gz
Initial commit, copied from imgurbash
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD27
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..43326175ad7b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sun Jun 12 16:02:51 UTC 2016
+pkgbase = imgur.sh
+ pkgdesc = An Imgur uploader bash script
+ pkgver = 6
+ pkgrel = 1
+ url = https://github.com/tremby/imgur.sh
+ arch = any
+ license = custom:PublicDomain
+ depends = curl
+ optdepends = xsel: copy the URL to clipboard (or xclip)
+ optdepends = xclip: copy the URL to clipboard (or xsel)
+ replaces = imgurbash
+ source = https://github.com/tremby/imgur.sh/archive/v6.tar.gz
+ sha256sums = a4334d64b6e7cf3deb1f4a5091e9ef3da5539b158f6953b2379ded836b2930f6
+
+pkgname = imgur.sh
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a484b264793a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Andrey Vihrov <andrey.vihrov at gmail.com>
+# Contributor: David Trail <david@vaunt.eu>
+# Contributor: Jan Stępień <jstepien@users.sourceforge.net>
+
+pkgname=imgur.sh
+pkgver=6
+pkgrel=1
+pkgdesc="An Imgur uploader bash script"
+arch=('any')
+url="https://github.com/tremby/imgur.sh"
+license=('custom:PublicDomain')
+depends=('curl')
+optdepends=('xsel: copy the URL to clipboard (or xclip)'
+ 'xclip: copy the URL to clipboard (or xsel)')
+replaces=('imgurbash')
+source=("https://github.com/tremby/imgur.sh/archive/v${pkgver}.tar.gz")
+sha256sums=('a4334d64b6e7cf3deb1f4a5091e9ef3da5539b158f6953b2379ded836b2930f6')
+
+package() {
+ cd "${pkgname}-${pkgver}"
+
+ install -D -m 0755 imgur.sh "${pkgdir}/usr/bin/imgur.sh"
+
+ install -D -m 0644 LICENCE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: