summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValHue2017-06-23 10:07:32 +0200
committerValHue2017-06-23 10:07:32 +0200
commit70cc6c12e9d46ed17aa8902b02f759ff38363752 (patch)
tree2024b695f09134616c78fe961f6813bfc012ad55
downloadaur-70cc6c12e9d46ed17aa8902b02f759ff38363752.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..06afac5d5ce6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = cover-thumbnailer-git
+ pkgdesc = Generates thumbnails for Nautilus folders (music album covers,...).
+ pkgver = 760a344
+ pkgrel = 1
+ url = https://github.com/flozz/cover-thumbnailer
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = gettext
+ depends = python2-pillow
+ depends = python2-gconf
+ provides = cover-thumbnailer
+ conflicts = cover-thumbnailer
+ source = cover-thumbnailer::git+https://github.com/flozz/cover-thumbnailer
+ sha256sums = SKIP
+
+pkgname = cover-thumbnailer-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0af7eefb46d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: ValHue <vhuelamo at gmail dot com>
+# https://github.com/ValHue/AUR-PKGBUILDs
+#
+_pkgname="cover-thumbnailer"
+pkgname="${_pkgname}-git"
+pkgver=760a344
+pkgrel=1
+pkgdesc="Generates thumbnails for Nautilus folders (music album covers,...)."
+arch=('i686' 'x86_64')
+url="https://github.com/flozz/cover-thumbnailer"
+license=('GPL3')
+depends=('python2-pillow' 'python2-gconf')
+makedepends=('gettext')
+conflicts=("${_pkgname}")
+provides=("${_pkgname}")
+source=("${_pkgname}::git+https://github.com/flozz/${_pkgname}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${_pkgname}
+ git describe --always | sed 's|-|.|g' | sed 's|_|.|g' | cut -d'.' -f2-
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ ./install.sh -p ${pkgdir}
+}
+
+# vim:set ts=4 sw=2 ft=sh et: