summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2019-07-29 18:42:04 +0200
committerhaawda2019-07-29 18:42:04 +0200
commit70d05d9e18560cb6a3289bb42e53f80ee29fa860 (patch)
treec050e6ea36344556a657f307def7673ae6373e73
downloadaur-70d05d9e18560cb6a3289bb42e53f80ee29fa860.tar.gz
initial upload
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD38
-rw-r--r--emacs-elpy.install21
3 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..64549585519d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = emacs-elpy
+ pkgdesc = Emacs Python Development Environment
+ pkgver = 1.29.1.r41.g7acdd14
+ pkgrel = 1
+ url = https://github.com/jorgenschaefer/elpy
+ install = emacs-elpy.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = emacs
+ depends = emacs-company-mode
+ depends = emacs-find-file-in-project
+ depends = emacs-highlight-indentation
+ depends = emacs-pyvenv
+ depends = emacs-yasnippet
+ depends = emacs-s
+ depends = python-elpy
+ provides = emacs-elpy
+ conflicts = emacs-elpy
+ source = elpy::git+https://github.com/jorgenschaefer/elpy
+ sha256sums = SKIP
+
+pkgname = emacs-elpy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b43c794670d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Alex Whitt <alex.joseph.whitt@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+_pkgsrcname=elpy
+_pkgmaintainer=jorgenschaefer
+_pkgdestdirname=elpy
+_versionprefix=
+pkgver=1.29.1.r41.g7acdd14
+pkgrel=1
+pkgdesc="Emacs Python Development Environment"
+pkgname=emacs-${_pkgdestdirname}
+arch=('any')
+url="https://github.com/${_pkgmaintainer}/${_pkgsrcname}"
+license=('GPL3')
+depends=('emacs' 'emacs-company-mode' 'emacs-find-file-in-project' 'emacs-highlight-indentation' 'emacs-pyvenv' 'emacs-yasnippet' 'emacs-s' 'python-elpy')
+source=("$_pkgsrcname::git+$url")
+sha256sums=('SKIP')
+makedepends=('git')
+conflicts=('emacs-elpy')
+provides=('emacs-elpy')
+install=emacs-${_pkgsrcname}.install
+
+pkgver() {
+ cd ${_pkgsrcname}
+ git describe --tags|sed 's+-+.r+'|tr - .
+}
+
+build() {
+ cd ${_pkgsrcname}
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd ${_pkgsrcname}
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/snippets/python-mode
+ install -m644 *.el "$pkgdir"/usr/share/emacs/site-lisp/
+ install -m644 snippets/python-mode/* "$pkgdir"/usr/share/emacs/site-lisp/snippets/python-mode/
+}
diff --git a/emacs-elpy.install b/emacs-elpy.install
new file mode 100644
index 000000000000..741174cd2e86
--- /dev/null
+++ b/emacs-elpy.install
@@ -0,0 +1,21 @@
+post_install () {
+
+cat << EOF
+
+==> Add this code to your .emacs file to use the mode:
+
+(require 'elpy)
+(elpy-enable)
+
+==> Or do the above with use-package:
+
+(use-package elpy
+ :config
+ (elpy-enable))
+
+EOF
+}
+
+post_upgrade () {
+ post_install $1
+}