summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2023-09-19 13:49:46 +0800
committerUniversebenzene2023-09-19 13:49:46 +0800
commit70f5b7f94f399e00d9f5263ce7cb2b433e33b4bc (patch)
tree88bf4ea6a27b8dc614f201c72ea87ca97e26ca54
parent679e239ec07c360b34a494b180af01fe4e37daf2 (diff)
downloadaur-70f5b7f94f399e00d9f5263ce7cb2b433e33b4bc.tar.gz
Update to version 2023.9.18
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb4ce199f823..7de1f0913eba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-tifffile
pkgdesc = Read and write image data from and to TIFF files
- pkgver = 2023.8.30
+ pkgver = 2023.9.18
pkgrel = 1
url = https://github.com/cgohlke/tifffile
arch = any
@@ -10,13 +10,13 @@ pkgbase = python-tifffile
makedepends = python-setuptools
makedepends = python-sphinx
makedepends = python-numpy
- source = https://files.pythonhosted.org/packages/source/t/tifffile/tifffile-2023.8.30.tar.gz
- sha256sums = 6a8c53b012a286b75d09a1498ab32f202f24cc6270a105b5d5911dc4426f162a
+ source = https://files.pythonhosted.org/packages/source/t/tifffile/tifffile-2023.9.18.tar.gz
+ sha256sums = 391d49e5e10a0f50f627b9083116f965e37d40bfe4e4713154e5edd57591590c
pkgname = python-tifffile
- depends = python-numpy>=1.25.1
- optdepends = python-matplotlib>=3.7.2: required for plotting
- optdepends = python-imagecodecs>=2023.8.12: required for encoding or decoding LZW, JPEG, etc. compressed segments
+ depends = python-numpy>=1.25.2
+ optdepends = python-matplotlib>=3.7.3: required for plotting
+ optdepends = python-imagecodecs>=2023.9.4: required for encoding or decoding LZW, JPEG, etc. compressed segments
optdepends = python-lxml>=4.9.2: required only for validating and printing XML
optdepends = python-zarr>=2.16.0: required for opening Zarr stores
optdepends = python-fsspec>=2023.6.0: required only for opening ReferenceFileSystem files
diff --git a/PKGBUILD b/PKGBUILD
index 85699102d748..56045b9685d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgbase=python-tifffile
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python-${_pyname}-doc")
-pkgver=2023.8.30
+pkgver=2023.9.18
pkgrel=1
pkgdesc="Read and write image data from and to TIFF files"
arch=('any')
@@ -18,7 +18,7 @@ checkdepends=('python-pytest'
'python-imagecodecs') # numpy ? xarray
# 'python-fsspec'
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-sha256sums=('6a8c53b012a286b75d09a1498ab32f202f24cc6270a105b5d5911dc4426f162a')
+sha256sums=('391d49e5e10a0f50f627b9083116f965e37d40bfe4e4713154e5edd57591590c')
build() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -55,9 +55,9 @@ check() {
}
package_python-tifffile() {
- depends=('python-numpy>=1.25.1')
- optdepends=('python-matplotlib>=3.7.2: required for plotting'
- 'python-imagecodecs>=2023.8.12: required for encoding or decoding LZW, JPEG, etc. compressed segments'
+ depends=('python-numpy>=1.25.2')
+ optdepends=('python-matplotlib>=3.7.3: required for plotting'
+ 'python-imagecodecs>=2023.9.4: required for encoding or decoding LZW, JPEG, etc. compressed segments'
'python-lxml>=4.9.2: required only for validating and printing XML'
'python-zarr>=2.16.0: required for opening Zarr stores'
'python-fsspec>=2023.6.0: required only for opening ReferenceFileSystem files'