summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorb00rt00s2015-06-08 22:12:30 +0200
committerb00rt00s2015-06-08 22:12:30 +0200
commit710e576434e42f94cd124573ffe4a2afde098005 (patch)
tree88a3f3d34d356213fc49cc0b0a04f0afbebc82e7
downloadaur-710e576434e42f94cd124573ffe4a2afde098005.tar.gz
Initial import
-rw-r--r--.SRCINFO28
-rw-r--r--GSASII.desktop9
-rw-r--r--PKGBUILD64
-rw-r--r--rungsas24
-rw-r--r--wxversion.patch13
5 files changed, 118 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..23baf964df3a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = gsas2-svn
+ pkgdesc = General Structure Analysis System II - refinement for powder diffraction patterns
+ pkgver = 1296
+ pkgrel = 1
+ url = https://subversion.xor.aps.anl.gov/trac/pyGSAS
+ arch = i686
+ arch = x86_64
+ license = unknown
+ makedepends = subversion
+ makedepends = scons
+ makedepends = gcc-fortran
+ depends = python2
+ depends = python2-scipy
+ depends = python2-matplotlib
+ depends = wxpython2.8
+ depends = python2-opengl
+ depends = python2-numpy
+ source = gsas2::svn+https://subversion.xor.aps.anl.gov/pyGSAS/trunk/
+ source = GSASII.desktop
+ source = rungsas2
+ source = wxversion.patch
+ md5sums = SKIP
+ md5sums = e9d06aed1866e65ce8259cfd5a31e1ce
+ md5sums = c114904d9eb6130abfb83e3d23adf005
+ md5sums = 9d61d13f5f9674c101359bac2f6f590d
+
+pkgname = gsas2-svn
+
diff --git a/GSASII.desktop b/GSASII.desktop
new file mode 100644
index 000000000000..7830ae5e9de2
--- /dev/null
+++ b/GSASII.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Encoding=UTF-8
+Version=1.0
+Type=Application
+Terminal=true
+Exec=/opt/gsas2/gsas2
+Name=GSAS II
+Icon=/opt/gsas2/gsas2.png
+Categories=Science;
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f62131470344
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Maintainer: b00rt00s ( bomby dot zrzuc at gmail dot com )
+# Committer: Zachary A. Jones <jazzplayerl9@gmail.com>
+
+pkgname=gsas2-svn
+_pkgname=gsas2
+pkgver=1296
+pkgrel=1
+pkgdesc="General Structure Analysis System II - refinement for powder diffraction patterns"
+arch=(i686 x86_64)
+url="https://subversion.xor.aps.anl.gov/trac/pyGSAS"
+license=(unknown)
+depends=(python2 python2-scipy python2-matplotlib wxpython2.8 python2-opengl python2-numpy)
+[ "${CARCH}" = "x86_64" ] && depends=("${depends[@]}")
+makedepends=(subversion scons gcc-fortran)
+source=("${_pkgname}::svn+https://subversion.xor.aps.anl.gov/pyGSAS/trunk/"
+ "GSASII.desktop"
+ "rungsas2"
+ "wxversion.patch")
+
+md5sums=('SKIP'
+ 'e9d06aed1866e65ce8259cfd5a31e1ce'
+ 'c114904d9eb6130abfb83e3d23adf005'
+ '9d61d13f5f9674c101359bac2f6f590d')
+
+pkgver() {
+ cd "${startdir}/${_pkgname}"
+ svnversion | tr -d [A-z]
+}
+
+build()
+{
+ #Build Fortran components using scons
+ cd "$srcdir/gsas2/fsource"
+ sed -i 's/f2py/f2py2/g' SConstruct
+ sed -i 's/python/python2/g' SConstruct
+ scons
+}
+
+package()
+{
+ mkdir -p "$pkgdir/opt/${_pkgname}"
+ mkdir -p "$pkgdir/usr/share/licenses/${_pkgname}/"
+ mkdir -p "$pkgdir/usr/share/applications/"
+
+ #Install gsas-2 files:
+ cp -a $srcdir/${_pkgname}/* $pkgdir/opt/${_pkgname}
+
+ #Install Desktop files:
+ install -m 644 -D "$srcdir/GSASII.desktop" "$pkgdir/usr/share/applications/GSASII.desktop"
+
+ #Install and link executables:
+ cp "$srcdir/rungsas2" "$pkgdir/opt/gsas2/${_pkgname}"
+ chmod +x "$pkgdir/opt/${_pkgname}/gsas2"
+
+ mkdir -p "$pkgdir/usr/bin"
+
+ #Linking executable
+ ( cd "$pkgdir/usr/bin"
+ ln -s ../../opt/${_pkgname}/gsas2 gsas2 )
+
+ #Patching for proper wx version'
+ ( cd $pkgdir/opt/gsas2
+ patch -p0 < $srcdir/wxversion.patch )
+}
diff --git a/rungsas2 b/rungsas2
new file mode 100644
index 000000000000..1687f4f36907
--- /dev/null
+++ b/rungsas2
@@ -0,0 +1,4 @@
+#!/bin/bash
+
+python2 /opt/gsas2/GSASII.py
+
diff --git a/wxversion.patch b/wxversion.patch
new file mode 100644
index 000000000000..f334479ffa84
--- /dev/null
+++ b/wxversion.patch
@@ -0,0 +1,13 @@
+*** GSASII.py 2014-04-23 14:50:53.990248150 +0000
+--- GSASII-new.py 2014-04-23 14:50:36.393581085 +0000
+***************
+*** 27,32 ****
+--- 27,34 ----
+ import inspect
+ import numpy as np
+ import scipy as sp
++ import wxversion
++ wxversion.select('2.8')
+ import wx
+ import matplotlib as mpl
+ try: