summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-07-08 04:30:00 +0300
committerDimitris Kiziridis2020-07-08 04:30:00 +0300
commit711569dd2e42a5eadec52895f4023e4c45e319c9 (patch)
treeb84085cb6e862f2b0948f71ac8ecf0ee28b43f08
parent8e73694435e92b28098a33ec28681bc64fb2f2e1 (diff)
downloadaur-711569dd2e42a5eadec52895f4023e4c45e319c9.tar.gz
add makedepends array
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea76d2e233f7..6b42d7287212 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = python-polib
pkgdesc = A library to manipulate gettext files
pkgver = 1.1.0
- pkgrel = 2
+ pkgrel = 3
url = https://pypi.python.org/pypi/polib
arch = any
license = MIT
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
depends = python
depends = python2
- source = https://pypi.io/packages/source/p/polib/polib-1.1.0.tar.gz
+ source = python-polib-1.1.0.tar.gz::https://pypi.io/packages/source/p/polib/polib-1.1.0.tar.gz
sha256sums = fad87d13696127ffb27ea0882d6182f1a9cf8a5e2b37a587751166c51e5a332a
pkgname = python-polib
diff --git a/PKGBUILD b/PKGBUILD
index 2d1ba7997e3a..92ba14fbc6bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
# Contributor: Esteban V. Carnevale <alfplayer@mailoo.com>
pkgbase=python-polib
-pkgname=(python-polib python2-polib)
+pkgname=('python-polib' 'python2-polib')
_pkgname=polib
pkgver=1.1.0
-pkgrel=2
+pkgrel=3
pkgdesc='A library to manipulate gettext files'
url='https://pypi.python.org/pypi/polib'
arch=('any')
license=('MIT')
depends=('python' 'python2')
-source=("https://pypi.io/packages/source/p/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+makedepends=('python-setuptools' 'python2-setuptools')
+source=("${pkgbase}-${pkgver}.tar.gz::https://pypi.io/packages/source/p/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
sha256sums=('fad87d13696127ffb27ea0882d6182f1a9cf8a5e2b37a587751166c51e5a332a')
build() {
@@ -30,4 +31,4 @@ package_python2-polib() {
cd "${srcdir}/${_pkgname}-${pkgver}"
python2 setup.py install --root="${pkgdir}" --optimize=1
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-}
+} \ No newline at end of file