summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Frankenau2016-11-10 18:21:07 +0100
committerJohannes Frankenau2016-11-10 18:21:07 +0100
commit7117bc305d4e0aa95ea2e626b502f8129b16ca97 (patch)
tree74a9f4b0dae5696d068a3a2d70fcfbbf2b7740c1
parentc650d777e6a9b4e5853511731312c5f527292450 (diff)
downloadaur-7117bc305d4e0aa95ea2e626b502f8129b16ca97.tar.gz
Update to version 0.2.0
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD17
3 files changed, 17 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64abefdca30d..2f9bafe43bd1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
-# Generated by mksrcinfo v8
-# Sun Dec 27 20:56:56 UTC 2015
pkgbase = cargo-script
- pkgdesc = Run Rust scripts
- pkgver = 0.1.4
- pkgrel = 2
+ pkgdesc = Quickly and easily run Rust "scripts"
+ pkgver = 0.2.0
+ pkgrel = 1
url = https://github.com/DanielKeep/cargo-script
arch = i686
arch = x86_64
license = MIT
depends = cargo
- source = https://github.com/DanielKeep/cargo-script/archive/v0.1.4/cargo-script-0.1.4.tar.gz
- sha256sums = 4872eca8c1c4b5886d9f93c5d7e4af67187ceff0b56012be1d6e9a6b18336f31
+ source = git+https://github.com/DanielKeep/cargo-script.git#commit=11ad368ff6dfa862629b2d0864dcaa958caba33f
+ sha256sums = SKIP
pkgname = cargo-script
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..98b91f7d307e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/cargo-script
+/pkg
+/src
+/*.pkg.tar
+/*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 624a00235398..b53a63689e37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,21 @@
-# Maintainer: Vlad M. <vlad@archlinux.net>
-
pkgname=cargo-script
-pkgver=0.1.4
-pkgrel=2
-pkgdesc="Run Rust "scripts""
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="Quickly and easily run Rust \"scripts\""
url="https://github.com/DanielKeep/cargo-script"
depends=('cargo')
arch=('i686' 'x86_64')
license=('MIT')
-source=("https://github.com/DanielKeep/$pkgname/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
-sha256sums=('4872eca8c1c4b5886d9f93c5d7e4af67187ceff0b56012be1d6e9a6b18336f31')
+source=("git+https://github.com/DanielKeep/cargo-script.git#commit=11ad368ff6dfa862629b2d0864dcaa958caba33f")
+sha256sums=('SKIP')
build() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname"
cargo build --release
}
package() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname"
install -Dm755 target/release/run-cargo-script "$pkgdir/usr/bin/run-cargo-script"
install -Dm755 target/release/cargo-script "$pkgdir/usr/bin/cargo-script"
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}