summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorroliboy2021-08-01 11:14:55 +0300
committerroliboy2021-08-01 11:14:55 +0300
commit712d6073037f882414ecb9d3d85bd676b5cbfd5e (patch)
tree82fd356db0e3e6c7778666d46e2f66c8e95192d3
parent1bc74f0077fab11f01917bfd37a9fe6410822e53 (diff)
downloadaur-712d6073037f882414ecb9d3d85bd676b5cbfd5e.tar.gz
update to version 3.3.0 and remove python-name-that-hash dependency
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD34
2 files changed, 21 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0ee369257a3..8cd301cdb731 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = python-pywhat
pkgdesc = Identify emails, IP addresses and more
- pkgver = 3.2.0
+ pkgver = 3.3.0
pkgrel = 1
url = https://github.com/bee-san/pyWhat
arch = any
license = GPL-3.0
- makedepends = python-setuptools
makedepends = python-dephell
+ makedepends = python-setuptools
depends = python
depends = python-click
- depends = python-name-that-hash
depends = python-rich
- source = python-pywhat-3.2.0.tar.gz::https://github.com/bee-san/pyWhat/archive/refs/tags/3.2.0.tar.gz
- sha256sums = f742745a30357f9a7f8c0117f4ec3c8808016a3dfbdc8568600a0cacd3e3acc2
+ source = python-pywhat-3.3.0.tar.gz::https://github.com/bee-san/pyWhat/archive/3.3.0.tar.gz
+ sha256sums = a81891c712f197e0f1446c0b52288b3ebdfafd125e3b8621cfd311d2468c4577
pkgname = python-pywhat
diff --git a/PKGBUILD b/PKGBUILD
index ae6dc8dccd16..fd764b96c916 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,37 +2,37 @@
pkgname=python-pywhat
_pkgname=pyWhat
-pkgver=3.2.0
+pkgver=3.3.0
pkgrel=1
pkgdesc="Identify emails, IP addresses and more"
-arch=('any')
+arch=("any")
depends=(
- 'python'
- 'python-click'
- 'python-name-that-hash' #aur
- 'python-rich'
+ "python"
+ "python-click"
+ "python-rich"
)
-makedepends=("python-setuptools" "python-dephell")
-url="https://github.com/bee-san/pyWhat"
-license=('GPL-3.0')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/bee-san/pyWhat/archive/refs/tags/$pkgver.tar.gz")
-sha256sums=(
- "f742745a30357f9a7f8c0117f4ec3c8808016a3dfbdc8568600a0cacd3e3acc2"
+makedepends=(
+ "python-dephell"
+ "python-setuptools"
)
+url="https://github.com/bee-san/pyWhat"
+license=("GPL-3.0")
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha256sums=("a81891c712f197e0f1446c0b52288b3ebdfafd125e3b8621cfd311d2468c4577")
prepare() {
- cd "$_pkgname-$pkgver"
+ cd "${_pkgname}-${pkgver}"
dephell deps convert --from pyproject.toml --to setup.py
}
build() {
- cd "$_pkgname-$pkgver"
+ cd "${_pkgname}-${pkgver}"
python setup.py build
}
package() {
- cd "$_pkgname-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}