summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Lönnqvist2021-07-05 13:18:33 +0300
committerBen Lönnqvist2021-07-05 13:18:33 +0300
commit7138cbafe540779dcf523b8c801a348064be8a7f (patch)
tree6176ba2193a367ad35dddb128ebf21b3e0626a09
downloadaur-7138cbafe540779dcf523b8c801a348064be8a7f.tar.gz
updpkg:python-aiohttp-security 0.4.0-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3b6d04696d6b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-aiohttp-security
+ pkgdesc = auth and permissions for aiohttp
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://aiohttp-security.readthedocs.io
+ arch = any
+ license = Apache
+ makedepends = python-setuptools
+ depends = python-aiohttp
+ source = https://files.pythonhosted.org/packages/source/a/aiohttp-security/aiohttp-security-0.4.0.tar.gz
+ sha256sums = 40d4bb150454e392c2dfa3620f6eab28e140e94cf0c2d3b4bf43aef653ec9405
+
+pkgname = python-aiohttp-security
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0147754925da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Ben 'silentnoodle' Lönnqvist <lonnqvistben at gmail dot com>
+
+pkgname=python-aiohttp-security
+pkgdesc='auth and permissions for aiohttp'
+pkgver=0.4.0
+pkgrel=1
+url='https://aiohttp-security.readthedocs.io'
+license=('Apache')
+arch=('any')
+depends=('python-aiohttp')
+makedepends=('python-setuptools')
+source=(
+ "https://files.pythonhosted.org/packages/source/a/aiohttp-security/aiohttp-security-$pkgver.tar.gz"
+)
+
+sha256sums=('40d4bb150454e392c2dfa3620f6eab28e140e94cf0c2d3b4bf43aef653ec9405')
+
+build() {
+ cd "aiohttp-security-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "aiohttp-security-$pkgver"
+ python setup.py install --skip-build --optimize=1 --prefix=/usr --root="$pkgdir"
+}