summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072017-09-03 17:39:25 +0200
committersL1pKn072017-09-03 17:39:25 +0200
commit714060413601a23a1a2e91bbf4b54d74e269c2bd (patch)
tree96a90285831adc6d4272a1f3e337e987381e4c20
downloadaur-714060413601a23a1a2e91bbf4b54d74e269c2bd.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD38
3 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1c898e19454e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Sep 3 15:39:25 UTC 2017
+pkgbase = vapoursynth-plugin-gradcurve-git
+ pkgdesc = Plugin for Vapoursynth: gradcurve (GIT version)
+ pkgver = r37.cce9deb
+ pkgrel = 1
+ url = https://github.com/xekon/GradCurve
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = vapoursynth
+ provides = vapoursynth-plugin-gradcurve
+ conflicts = vapoursynth-plugin-gradcurve
+ source = gradcurve::git+https://github.com/xekon/GradCurve.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-gradcurve-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..611c8617be2c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=gradcurve
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r37.cce9deb
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('i686' 'x86_64')
+url='https://github.com/xekon/GradCurve'
+license=('GPL')
+depends=('vapoursynth')
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/xekon/GradCurve.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ #echo "$(git describe --long --tags | tr - .)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${_plug}"
+ ./configure \
+ --install="${pkgdir}/usr/lib/vapoursynth" \
+ --extra-cxxflags="${CPPFLAGS} ${CXXFLAGS}" \
+ --extra-ldflags="${LDDFLAGS}"
+
+ make
+}
+
+package(){
+ cd "${_plug}"
+ make install
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+}