summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Carr2019-06-21 18:34:42 -0700
committerDonald Carr2019-06-21 18:58:13 -0700
commit717e68571b309b60acd8b535ceaa70a4cb4ad509 (patch)
treefb37786b2e609bacd5e048e14c5d8d0366de7481
parent93e5443ac351ce1d1960bc2f9ac95802b6cd42a9 (diff)
downloadaur-717e68571b309b60acd8b535ceaa70a4cb4ad509.tar.gz
Add pacman hook to recompile qt-gtk-platform-plugin-git on qt5-base upgrade
Change-Id: If25a695afe6175227babe2e57044d2915fc5232b
-rw-r--r--.SRCINFO4
-rw-r--r--100-qt-gtk-platform-plugin-git.hook9
-rw-r--r--PKGBUILD9
3 files changed, 18 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e005692124bb..f20b0075d6a0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Mar 28 07:10:30 UTC 2018
+# Sat Jun 22 01:58:06 UTC 2019
pkgbase = qt-gtk-platform-plugin-git
pkgdesc = GTK platform backend for Qt
- pkgver = 20180218.def7d52
+ pkgver = 20190427.da0e695
pkgrel = 1
url = https://github.com/CrimsonAS/gtkplatform
arch = any
diff --git a/100-qt-gtk-platform-plugin-git.hook b/100-qt-gtk-platform-plugin-git.hook
new file mode 100644
index 000000000000..b3d38a450c3e
--- /dev/null
+++ b/100-qt-gtk-platform-plugin-git.hook
@@ -0,0 +1,9 @@
+[Trigger]
+Type = Package
+Operation = Upgrade
+Target = qt5-base
+
+[Action]
+Description = Updating qt-gtk-platform-plugin-git
+When = PostTransaction
+Exec = /usr/bin/sudo -u #1000 /usr/bin/yay -S qt-gtk-platform-plugin-git
diff --git a/PKGBUILD b/PKGBUILD
index 37f44954fac3..71c1a6380397 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _pkgname=qt-gtk-platform-plugin
pkgname=${_pkgname}-git
provides=($_pkgname)
conflicts=($_pkgname)
-pkgver=20180218.def7d52
+pkgver=20190427.da0e695
pkgrel=1
pkgdesc='GTK platform backend for Qt'
arch=('any')
@@ -27,9 +27,14 @@ build() {
package() {
local env_dir=${pkgdir}/usr/share/gdm/env.d/
+ local pacman_hook_dir=${pkgdir}/etc/pacman.d/hooks
local env_file=${startdir}/qt-force-gtk-platform.env
+ local hook_file=${startdir}/100-qt-gtk-platform-plugin-git.hook
- mkdir -p $env_dir
+ mkdir -p ${env_dir} ${pacman_hook_dir}
+
+ # FIXME: assumption riddled and does not permit input at present
+ #cp ${hook_file} ${pacman_hook_dir}
cp ${env_file} ${env_dir}
cd "${srcdir}/gtkplatform"