summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authora8212024-03-25 19:10:01 +0100
committera8212024-03-25 19:10:01 +0100
commit719150254c1c1475dc6a23ec029f0be4edf6e4f3 (patch)
tree42b2771ddbacf5619399fae3ed40b34331c68db0
parent129a26cf6f42156a25c3fba3cd259ec076461d3e (diff)
downloadaur-719150254c1c1475dc6a23ec029f0be4edf6e4f3.tar.gz
sync with official package
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f78c5d089f21..391ecb7bff52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Morten Linderud <foxboron archlinux.org>
pkgname=gopass-git
-pkgver=1.15.7.r2.g439bc002
+pkgver=1.15.12.r4.g57f19d2c
pkgrel=1
pkgdesc="The slightly more awesome standard unix password manager for teams."
arch=('x86_64' 'i686' 'armv6h' 'armv7h')
@@ -28,6 +28,7 @@ pkgver() {
prepare() {
cd gopass
sed -i 's|-gcflags="-trimpath=$(GOPATH)" -asmflags="-trimpath=$(GOPATH)"||' Makefile
+ sed -i 's|CGO_ENABLED=0||' Makefile
}
build() {
@@ -36,7 +37,7 @@ build() {
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
- export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
make
}