summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralium2020-08-12 12:36:30 +0200
committeralium2020-08-12 12:36:30 +0200
commit71d3c2b0e523e67e6da39f9dfc40c393fcff1435 (patch)
treeeb68211434a619efc94934c40f0ce920c4b8aa61
parent2b483cf3bb37defd826a28cbdaa6862ebd3a9213 (diff)
downloadaur-71d3c2b0e523e67e6da39f9dfc40c393fcff1435.tar.gz
Update to 2.4.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
-rw-r--r--gcc10-2.patch27
-rw-r--r--gcc10.patch29
4 files changed, 8 insertions, 75 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 318cfe4bc027..a550c60ff49f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libva-intel-driver-g45-h264
pkgdesc = Video Acceleration (VA) API for Linux
- pkgver = 2.4.0
- pkgrel = 2
+ pkgver = 2.4.1
+ pkgrel = 1
epoch = 1
url = https://01.org/linuxmedia/vaapi
arch = i686
@@ -17,12 +17,8 @@ pkgbase = libva-intel-driver-g45-h264
conflicts = libva-intel-driver
conflicts = intel-gpu-tools
replaces = libva-intel-driver
- source = https://bitbucket.org/alium/g45-h264/downloads/intel-driver-g45-h264-2.4.0-2.tar.gz
- source = gcc10.patch
- source = gcc10-2.patch
- sha256sums = 6850c0e519b09bd720bab8bdbf8e53974c44fec7ebca7389990cd1262ce35f09
- sha256sums = ca9db2bace98932deadc1301d57194b8ad777ecb43b31b10e76b2b6b1ac2bfd9
- sha256sums = f87c8398a26faf50fa23769a3bbbedb865ced964a2257a14211eb3434c4a5658
+ source = https://bitbucket.org/alium/g45-h264/downloads/intel-driver-g45-h264-2.4.1.tar.gz
+ sha256sums = f9d18a4b9d5007bc606d125b553a3d053d3295dd295ea477e43396a751e706fd
pkgname = libva-intel-driver-g45-h264
diff --git a/PKGBUILD b/PKGBUILD
index db6261bd29f0..f54cb0545914 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=libva-intel-driver-g45-h264
epoch=1
-pkgver=2.4.0
-pkgrel=2
+pkgver=2.4.1
+pkgrel=1
pkgdesc="VA-API implementation for Intel G45 chipsets with H264 support."
arch=('i686' 'x86_64')
url='https://01.org/linuxmedia/vaapi'
@@ -17,18 +17,13 @@ optdepends=('libva-utils: Applications and Scripts for libva (vainfo and others)
license=(MIT)
makedepends=(mesa)
-source=(https://bitbucket.org/alium/g45-h264/downloads/intel-driver-g45-h264-$pkgver-2.tar.gz
- gcc10.patch gcc10-2.patch)
+source=(https://bitbucket.org/alium/g45-h264/downloads/intel-driver-g45-h264-$pkgver.tar.gz)
prepare () {
cd intel-vaapi-driver
# Only relevant if intel-gpu-tools is installed,
# since then the shaders will be recompiled
sed -i '1s/python$/&2/' src/shaders/gpp.py
-
- # fix gcc10 errors
- patch -Np1 -i ../gcc10.patch
- patch -Np1 -i ../gcc10-2.patch
}
build() {
@@ -44,6 +39,4 @@ package() {
install -m644 -D COPYING ${pkgdir}/usr/share/licenses/${pkgname}/COPYING
}
-sha256sums=('6850c0e519b09bd720bab8bdbf8e53974c44fec7ebca7389990cd1262ce35f09'
- 'ca9db2bace98932deadc1301d57194b8ad777ecb43b31b10e76b2b6b1ac2bfd9'
- 'f87c8398a26faf50fa23769a3bbbedb865ced964a2257a14211eb3434c4a5658')
+sha256sums=('f9d18a4b9d5007bc606d125b553a3d053d3295dd295ea477e43396a751e706fd')
diff --git a/gcc10-2.patch b/gcc10-2.patch
deleted file mode 100644
index 2fa8e7fbd5b6..000000000000
--- a/gcc10-2.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 10b74f1b4ab9a742d98f81aad57399ff682975a4 Mon Sep 17 00:00:00 2001
-From: "U. Artie Eoff" <ullysses.a.eoff@intel.com>
-Date: Tue, 12 May 2020 11:03:26 -0700
-Subject: [PATCH] test: cast VA_STATSUS_ERROR_UNKNOWN to VAStatus
-
-This fixes a gcc10 compiler error for the
-VA_STATUS_ERROR_UNKNOWN 0xFFFFFFFF conversion from
-unsigned int to int.
-
-Signed-off-by: U. Artie Eoff <ullysses.a.eoff@intel.com>
----
- test/test.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/test/test.h b/test/test.h
-index 5d3fdc8c..fc23ad12 100644
---- a/test/test.h
-+++ b/test/test.h
-@@ -147,7 +147,7 @@ class VaapiStatus
- status = "VA_STATUS_ERROR_HW_BUSY"; break;
- case VA_STATUS_ERROR_UNSUPPORTED_MEMORY_TYPE:
- status = "VA_STATUS_ERROR_UNSUPPORTED_MEMORY_TYPE"; break;
-- case VA_STATUS_ERROR_UNKNOWN:
-+ case VAStatus(VA_STATUS_ERROR_UNKNOWN):
- status = "VA_STATUS_ERROR_UNKNOWN"; break;
- default:
- status = "Unknown VAStatus";
diff --git a/gcc10.patch b/gcc10.patch
deleted file mode 100644
index 1f243de1e006..000000000000
--- a/gcc10.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From fc1c4ac1422cbb416817eb37af7d7007b97b8ec0 Mon Sep 17 00:00:00 2001
-From: "U. Artie Eoff" <ullysses.a.eoff@intel.com>
-Date: Tue, 12 May 2020 11:01:30 -0700
-Subject: [PATCH] Fix HEVCe kernel compile error on gcc10
-
-This fixes a "multiple definition" compiler error on
-gcc10 which defaults to -fno-common.
-
-https://gcc.gnu.org/gcc-10/porting_to.html#common
-
-Fixes #503
-
-Signed-off-by: U. Artie Eoff <ullysses.a.eoff@intel.com>
----
- src/gen9_hevc_enc_kernels_binary.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/gen9_hevc_enc_kernels_binary.h b/src/gen9_hevc_enc_kernels_binary.h
-index 29659fa0..ff7d0af5 100644
---- a/src/gen9_hevc_enc_kernels_binary.h
-+++ b/src/gen9_hevc_enc_kernels_binary.h
-@@ -31,6 +31,6 @@
-
- #define GEN9_HEVC_ENC_KERNEL_SIZE 149296
-
--const unsigned int gen9_hevc_encoder_kernels[GEN9_HEVC_ENC_KERNEL_SIZE];
-+extern const unsigned int gen9_hevc_encoder_kernels[GEN9_HEVC_ENC_KERNEL_SIZE];
-
- #endif