summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiretza2020-05-23 13:58:57 +0200
committerXiretza2020-05-23 13:58:57 +0200
commit720a5d01b5a1261e227327b476cc8d17e00d7236 (patch)
tree457bed70c507399acdf87793695fbdf88faf145f
downloadaur-720a5d01b5a1261e227327b476cc8d17e00d7236.tar.gz
Initial import
based on the formerly combined python2+python3 package from the repos: https://git.archlinux.org/svntogit/packages.git/tree/trunk?h=packages/python-beaker&id=b2bbd309fff6333ea52f23dadac9c546eb76b238
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD37
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5ba45eac9118
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-beaker
+ pkgdesc = Caching and sessions WSGI middleware for use with web applications and stand-alone Python scripts and applications
+ pkgver = 1.11.0
+ pkgrel = 4
+ url = https://beaker.readthedocs.io/
+ arch = any
+ license = custom
+ makedepends = python2-setuptools
+ depends = python2-funcsigs
+ source = python2-beaker-1.11.0.tar.gz::https://github.com/bbangert/beaker/archive/1.11.0.tar.gz
+ sha512sums = 0eab9ff40314786e0fb2d31a6b932f355680c193ac5c41de442ee5a3f4d5cf62ae1c30f2948f8e2c89c012bad5e4332a5a72be62c9b1cba0b9f2723afe7e9ae3
+
+pkgname = python2-beaker
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6c109912ddb9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: xiretza <xiretza+aur@gmail.com>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
+# Contributor: Massimiliano Torromeo < massimiliano DOT torromeo AT gmail DOT com >
+
+pkgname=python2-beaker
+pkgver=1.11.0
+pkgrel=4
+arch=('any')
+license=('custom')
+pkgdesc="Caching and sessions WSGI middleware for use with web applications and stand-alone Python scripts and applications"
+url="https://beaker.readthedocs.io/"
+makedepends=('python2-setuptools')
+depends=('python2-funcsigs')
+
+source=("$pkgname-$pkgver.tar.gz::https://github.com/bbangert/beaker/archive/$pkgver.tar.gz")
+sha512sums=('0eab9ff40314786e0fb2d31a6b932f355680c193ac5c41de442ee5a3f4d5cf62ae1c30f2948f8e2c89c012bad5e4332a5a72be62c9b1cba0b9f2723afe7e9ae3')
+
+prepare() {
+ # Use a fake MongoDB for tests
+ sed -e '/class TestMongoDB/i import mongomock' \
+ -e "s|'mongodb://localhost:27017/beaker_testdb'|mongomock.MongoClient('mongodb://localhost:27017/beaker_testdb')|" \
+ -i beaker-$pkgver/tests/test_managers/test_ext_mongodb.py
+
+ sed -i "s#/usr/bin/python#/usr/bin/python2#" "beaker-$pkgver/beaker/crypto/pbkdf2.py"
+}
+
+build() {
+ cd "$srcdir/beaker-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/beaker-$pkgver"
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/python2-beaker/LICENSE"
+}