summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2020-01-30 15:49:41 +0100
committerPiotr Gorski2020-01-30 15:49:41 +0100
commit721efacc2593072c2d7fefd8e799f10da2aa949a (patch)
tree39c4c32e7dcfba01af65ef6bbf06f05ab2f1f2c5
parent6b2553a628c62846d07427d93570c9fee9a338f9 (diff)
downloadaur-721efacc2593072c2d7fefd8e799f10da2aa949a.tar.gz
Set PSI_PLUS
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4bd64f3c9af0..05ced0470a80 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = psi-plus-git
pkgdesc = Psi+ is a powerful XMPP client (Qt, C++) designed for the XMPP power users (built with Qt 5.x)
- pkgver = 1.4.983.r1143.ga6c79a5
+ pkgver = 1.4.1006.r1148.gbbaafae
pkgrel = 1
url = https://psi-plus.com
arch = x86_64
@@ -18,8 +18,8 @@ pkgbase = psi-plus-git
depends = qt5-svg
depends = hunspell
depends = qtkeychain
- provides = psi-plus=1.4.983.r1143.ga6c79a5
- provides = psi-plus-qt5-git=1.4.983.r1143.ga6c79a5
+ provides = psi-plus=1.4.1006.r1148.gbbaafae
+ provides = psi-plus-qt5-git=1.4.1006.r1148.gbbaafae
conflicts = psi-plus
conflicts = psi-plus-qt5-git
conflicts = psi-plus-webkit-qt5-git
diff --git a/PKGBUILD b/PKGBUILD
index 4bcc60dedd68..d21ee23b2e84 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Alexey D. <lq07829icatm@rambler.ru>
pkgname=psi-plus-git
-pkgver=1.4.983.r1143.ga6c79a5
+pkgver=1.4.1006.r1148.gbbaafae
pkgrel=1
pkgdesc="Psi+ is a powerful XMPP client (Qt, C++) designed for the XMPP power users (built with Qt 5.x)"
url="https://psi-plus.com"
@@ -24,16 +24,15 @@ sha256sums=('SKIP'
'SKIP'
'SKIP')
-
pkgver() {
cd psi-plus
_ver="$(cat "${srcdir}/psi/version" | cut -d ' ' -f 1)"
echo "${_ver}.r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}
-
+
prepare() {
cd psi
-
+
# makepkg doesn't support --recursive
# so setup git modules manually
git submodule init
@@ -48,9 +47,6 @@ prepare() {
patch -p1 -i "$patch"
done
- # additional icon themes
- cp -a "$srcdir"/psi-plus/iconsets .
-
# set version
cd $srcdir/psi-plus/admin
sh psi-plus-nightly-version $srcdir/psi > $srcdir/psi/version
@@ -60,7 +56,7 @@ build() {
cd psi
mkdir -p build
cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DCHAT_TYPE=WEBENGINE ..
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DPSI_PLUS=ON -DCHAT_TYPE=WEBENGINE ..
make
}