summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão Figueiredo2020-09-12 15:29:53 +0100
committerJoão Figueiredo2020-09-12 15:29:53 +0100
commit723706bda4c50b96451aa34a749ff22ebf6d95ee (patch)
treedd2a320ec37e0ce402d926347fe450386e36df43
downloadaur-723706bda4c50b96451aa34a749ff22ebf6d95ee.tar.gz
First commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD33
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6c6f971efbf6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = elf-dissector-git
+ pkgdesc = Static analysis tool for ELF libraries and executables
+ pkgver = r762.42931ca
+ pkgrel = 1
+ url = https://invent.kde.org/sdk/elf-dissector
+ arch = x86_64
+ license = GPL
+ makedepends = extra-cmake-modules
+ makedepends = git
+ makedepends = kitemmodels
+ depends = harfbuzz
+ depends = hicolor-icon-theme
+ depends = libdwarf
+ depends = qt5-base
+ optdepends = capstone: disassembler
+ optdepends = gnuplot: performance plot
+ source = git+https://github.com/KDE/elf-dissector.git
+ sha256sums = SKIP
+
+pkgname = elf-dissector-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..daa0f84381ed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: João Figueiredo <jf dot mundox at gmail dot com>
+
+pkgname=elf-dissector-git
+pkgver=r762.42931ca
+pkgrel=1
+pkgdesc="Static analysis tool for ELF libraries and executables"
+arch=('x86_64')
+url="https://invent.kde.org/sdk/elf-dissector"
+license=('GPL')
+depends=('harfbuzz' 'hicolor-icon-theme' 'libdwarf' 'qt5-base')
+optdepends=('capstone: disassembler'
+ 'gnuplot: performance plot')
+makedepends=('extra-cmake-modules' 'git' 'kitemmodels')
+source=('git+https://github.com/KDE/elf-dissector.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-git}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd ${pkgname%-git}
+ mkdir -p build
+ cd build
+ cmake ..
+ make
+}
+
+package() {
+ cd ${pkgname%-git}/build
+ make DESTDIR="$pkgdir" install
+}