summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime “pep” Buquet2019-04-24 15:14:01 +0100
committerMaxime “pep” Buquet2019-04-24 15:14:01 +0100
commit72796282a112357edbff6020285e9969a3475714 (patch)
treeecbc2d3e64328b6fe285766a172ce7de3865c2e2
downloadaur-72796282a112357edbff6020285e9969a3475714.tar.gz
Initial commit
Signed-off-by: Maxime “pep” Buquet <pep@bouah.net>
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD27
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b543f5127a17
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = git-pw
+ pkgdesc = A tool for integrating Git with Patchwork, the web-based patch tracking system
+ pkgver = 1.5.1
+ pkgrel = 1
+ url = https://github.com/getpatchwork/git-pw
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-requests
+ depends = python-click
+ depends = python-pbr
+ depends = python-arrow
+ depends = python-tabulate
+ source = git-pw::git+https://github.com/getpatchwork/git-pw.git#tag=1.5.1
+ sha256sums = SKIP
+
+pkgname = git-pw
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..560d4a7d07c9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Maxime "pep" Buquet <archlinux@bouah.net>
+
+_pkgname=git-pw
+_tag=1.5.1
+pkgname=${_pkgname}
+pkgver=${_tag}
+pkgrel=1
+pkgdesc="A tool for integrating Git with Patchwork, the web-based patch tracking system"
+url='https://github.com/getpatchwork/git-pw'
+license=('MIT')
+arch=('any')
+depends=(
+ 'python-requests'
+ 'python-click'
+ 'python-pbr'
+ 'python-arrow'
+ 'python-tabulate'
+)
+makedepends=('python-setuptools')
+source=("${_pkgname}::git+https://github.com/getpatchwork/git-pw.git#tag=${_tag}")
+sha256sums=('SKIP')
+
+package() {
+ cd ${_pkgname}
+ python setup.py install --root="${pkgdir}" --optimize=1
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}