summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Fink2023-03-26 19:03:00 +0300
committerChristoph Fink2023-03-26 19:03:00 +0300
commit728fdc73c58a7e4f24e11f39bbc579abb0c74c46 (patch)
tree4fa62eedefc50a9d4614d911bf369c0e8c53456b
parent25da1d71e9278134a847a75c1a17d9c8d160def6 (diff)
downloadaur-728fdc73c58a7e4f24e11f39bbc579abb0c74c46.tar.gz
upgpkg: r-sfheaders 0.4.2-3
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD35
2 files changed, 26 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0396b2f8d6f4..32b9da8e0163 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,11 @@
pkgbase = r-sfheaders
pkgdesc = Converts Between R Objects and Simple Feature Objects
pkgver = 0.4.2
- pkgrel = 2
+ pkgrel = 3
url = https://cran.r-project.org/package=sfheaders
arch = i686
arch = x86_64
license = MIT
- checkdepends = r-covr
- checkdepends = r-knitr
- checkdepends = r-testthat
depends = r>=3.0.2
depends = r-geometries>=0.2.2
depends = r-rcpp>=1.0.10
diff --git a/PKGBUILD b/PKGBUILD
index 3bafd6cf5907..3e87e1436ca9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgdesc="Converts Between R Objects and Simple Feature Objects"
url="https://cran.r-project.org/package=sfheaders"
license=("MIT")
pkgver=${_cranver//[:-]/.}
-pkgrel=2
+pkgrel=3
arch=("i686" "x86_64")
depends=(
@@ -19,27 +19,42 @@ optdepends=(
"r-covr"
"r-knitr"
)
-checkdepends=(
- "${optdepends[@]}"
- "r-testthat"
-)
+
+# The unittests for `r-sfheaders` have multiple circular
+# dependency chains.
+
+# As such, the tests can not be run on first build.
+# While R packages from CRAN, generally, are well-tested
+# before they are released, in some situations, you want to
+# have thorough testing on your own end.
+
+# To run the tests, first build this package without `check()`
+# (i.e., as-is) to bootstrap `r-sfheaders`. Then, on subsequent builds,
+# (assumining you have a local repository that is accessible from
+# the build chroot), uncomment the lines defining `checkdepends`, below,
+# as well as the `check()` function further down
+
+# checkdepends=(
+# "${optdepends[@]}"
+# "r-testthat"
+# )
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-b2sums=('2652abb2afda69455faab4b74ae28f397a83793cdc387a00b001f7535bc8ee220534a52cf0d78896c084ca9173af177e0a03394d0594521f13ac4310bfebca2b')
+b2sums=("2652abb2afda69455faab4b74ae28f397a83793cdc387a00b001f7535bc8ee220534a52cf0d78896c084ca9173af177e0a03394d0594521f13ac4310bfebca2b")
build() {
mkdir -p "${srcdir}/build/"
R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}/build/"
}
-check() {
- R_LIBS="build/" R CMD check --no-manual --as-cran "${_cranname}"
-}
+# check() {
+# export R_LIBS="build/"
+# R CMD check --no-manual "${_cranname}"
+# }
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"
cp -a --no-preserve=ownership "${srcdir}/build/${_cranname}" "${pkgdir}/usr/lib/R/library"
-
if [[ -f "${_cranname}/LICENSE" ]]; then
install -Dm0644 "${_cranname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
fi