summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2017-02-26 20:52:05 +0000
committerAntonio Rojas2017-02-26 20:52:05 +0000
commit72c1f873e51030182206922afff08c153a7228f1 (patch)
treeb2c84eda0b17f78e226bebb3ef06e6f935d0b7ad
downloadaur-72c1f873e51030182206922afff08c153a7228f1.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3a7fb653bbb8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = jupyter-singular
+ pkgdesc = Jupyter kernel for Singular
+ pkgver = 0.9.2
+ pkgrel = 1
+ url = https://github.com/sebasguts/jupyter_kernel_singular
+ arch = any
+ license = GPL
+ depends = python-pysingular
+ depends = jupyter-notebook
+ depends = python-ipywidgets
+ source = https://pypi.io/packages/source/j/jupyter_kernel_singular/jupyter_kernel_singular-0.9.2.tar.gz
+ md5sums = 915e2e89b759297a8aebcfe8ca400cbb
+
+pkgname = jupyter-singular
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e552f7a6b31
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Antonio Rojas <arojas@archlinux.org>
+
+pkgname=jupyter-singular
+pkgver=0.9.2
+pkgrel=1
+pkgdesc="Jupyter kernel for Singular"
+arch=(any)
+url="https://github.com/sebasguts/jupyter_kernel_singular"
+license=(GPL)
+depends=(python-pysingular jupyter-notebook python-ipywidgets)
+source=(https://pypi.io/packages/source/j/jupyter_kernel_singular/jupyter_kernel_singular-$pkgver.tar.gz)
+md5sums=('915e2e89b759297a8aebcfe8ca400cbb')
+
+build() {
+ cd jupyter_kernel_singular-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd jupyter_kernel_singular-$pkgver
+ python setup.py install --skip-build --root="$pkgdir" --optimize=1
+}