summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas2018-10-26 17:24:18 +0200
committerAndreas2018-10-26 17:24:18 +0200
commit72c56aab9b601c0a923fcb0274aaa6e7eabc2477 (patch)
tree1d238621bcc6022ccbbb2bc42584e232639f5650
parent46c902330af05aa72fb8f819bfcf216256621a75 (diff)
downloadaur-72c56aab9b601c0a923fcb0274aaa6e7eabc2477.tar.gz
version 1.3
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD9
-rw-r--r--nagelfar-paths.patch48
3 files changed, 40 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b2f4e603bf2a..b06eeb7e934c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
-# Generated by mksrcinfo v8
-# Fri May 4 18:26:32 UTC 2018
pkgbase = nagelfar
pkgdesc = Tcl syntax checker
- pkgver = 1.2.5
+ pkgver = 1.3.0
pkgrel = 1
url = http://nagelfar.sourceforge.net/
arch = any
license = GPL
depends = tcl
- source = http://downloads.sourceforge.net/nagelfar/Rel_125/nagelfar125.tar.gz
+ source = http://downloads.sourceforge.net/nagelfar/Rel_130/nagelfar130.tar.gz
source = nagelfar-paths.patch
source = doc-syntaxdatabase.patch
- md5sums = 707e3c305437dce1f14103f0bd058fc9
- md5sums = 80a3e5df0bf55548a29329948a3b541c
+ md5sums = b6405edd980c714d39e425f8311368b2
+ md5sums = 53bcf49957b3a79c87c411e89824b6c5
md5sums = 48f75a0c131cc17df6b38a2f5967c7e4
pkgname = nagelfar
diff --git a/PKGBUILD b/PKGBUILD
index 99ced1b2706a..f91671513684 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Testudo Aquatilis
pkgname=nagelfar
_pkgver_main=1
-_pkgver_sub=2
-_pkgver_subsub=5
+_pkgver_sub=3
+_pkgver_subsub=0
pkgver="${_pkgver_main}.${_pkgver_sub}.${_pkgver_subsub}"
_pkgver="${_pkgver_main}${_pkgver_sub}${_pkgver_subsub}"
pkgrel=1
@@ -25,8 +25,8 @@ install=
changelog=
source=("http://downloads.sourceforge.net/nagelfar/Rel_${_pkgver}/${pkgname}${_pkgver}.tar.gz" nagelfar-paths.patch doc-syntaxdatabase.patch)
noextract=()
-md5sums=('707e3c305437dce1f14103f0bd058fc9'
- '80a3e5df0bf55548a29329948a3b541c'
+md5sums=('b6405edd980c714d39e425f8311368b2'
+ '53bcf49957b3a79c87c411e89824b6c5'
'48f75a0c131cc17df6b38a2f5967c7e4')
validpgpkeys=()
@@ -37,7 +37,6 @@ prepare() {
patch -Np1 -i "${srcdir}/nagelfar-paths.patch"
}
-
package() {
cd ${pkgname}${_pkgver}
diff --git a/nagelfar-paths.patch b/nagelfar-paths.patch
index 1e1b7ef66af4..d69622dbacf3 100644
--- a/nagelfar-paths.patch
+++ b/nagelfar-paths.patch
@@ -1,24 +1,40 @@
--- a/nagelfar.tcl
+++ b/nagelfar.tcl
-@@ -28,7 +28,7 @@
- #----------------------------------------------------------------------
+@@ -34,32 +34,13 @@
+ # This variable should be overwritten by the build process
+ set version "Version ??? ???"
- set debug 0
--package require Tcl 8.4
-+package require Tcl 8.5
+-# Allow thisScript to be predefined (used for test)
+-if {![info exists thisScript]} {
+- set thisScript [file normalize [file join [pwd] [info script]]]
+-}
+-set thisDir [file dirname $thisScript]
++# This makes it possible to customize where files are installed
++set dbDir /usr/lib/nagelfar
++set docDir /usr/share/doc/nagelfar
++set libDir /usr/lib/nagelfar/lib
- package provide app-nagelfar 1.0
- # This variable should be overwritten by the build process
-@@ -50,9 +50,9 @@
- unset tmplink
+-# Follow any link
+-set tmplink $thisScript
+-while {[file type $tmplink] == "link"} {
+- set tmplink [file readlink $tmplink]
+- set tmplink [file normalize [file join $thisDir $tmplink]]
+- set thisDir [file dirname $tmplink]
+-}
+-unset tmplink
++lappend auto_path $libDir
- # This makes it possible to customize where files are installed
+-# This makes it possible to customize where files are installed
-set dbDir $thisDir
-set docDir $thisDir/doc
-set libDir $thisDir/lib
-+set dbDir /usr/lib/nagelfar
-+set docDir /usr/share/doc/nagelfar
-+set libDir /usr/lib/nagelfar/lib
-
- # Search where the script is, to be able to place e.g. ctext there.
- if {[info exists ::starkit::topdir]} {
+-
+-# Search where the script is, to be able to place e.g. ctext there.
+-if {[info exists ::starkit::topdir]} {
+- lappend auto_path [file dirname [file normalize $::starkit::topdir]]
+-} else {
+- lappend auto_path $libDir
+-}
+ set version "Version 1.3.0 2018-10-03"
+ #----------------------------------------------------------------------
+ # Nagelfar, a syntax checker for Tcl.