summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Kluger2021-04-30 01:12:06 -0400
committerAndy Kluger2021-04-30 01:12:06 -0400
commit72d1d2a13c09e0afac713ed49216e12368787560 (patch)
treeee6ff68c7313d5df2c97a5bbb70e07303234c886
parentea04239f10b689092cf63b8ffdde299c387aae09 (diff)
downloadaur-72d1d2a13c09e0afac713ed49216e12368787560.tar.gz
new version scheme, shallow checkouts
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD23
2 files changed, 13 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d6c048eb929..99fbb2b0590e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ttf-iosevka-git
pkgdesc = A slender monospace sans-serif and slab-serif typeface inspired by Pragmata Pro, M+ and PF DIN Mono.
- pkgver = r2089.115f5b19
+ pkgver = 1619488675
pkgrel = 1
url = https://be5invis.github.io/Iosevka/
arch = any
@@ -11,8 +11,6 @@ pkgbase = ttf-iosevka-git
makedepends = ttfautohint
provides = ttf-iosevka
conflicts = ttf-iosevka
- source = git+https://github.com/be5invis/Iosevka
- sha256sums = SKIP
pkgname = ttf-iosevka-git
diff --git a/PKGBUILD b/PKGBUILD
index 33dc26942128..5a194e294bdf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Markus Weimar <mail@markusweimar.de>
_pkgname=ttf-iosevka
pkgname=${_pkgname}-git
-pkgver=r2089.115f5b19
+pkgver=1619488675
pkgrel=1
pkgdesc='A slender monospace sans-serif and slab-serif typeface inspired by Pragmata Pro, M+ and PF DIN Mono.'
arch=('any')
@@ -12,26 +12,27 @@ makedepends=('git' 'nodejs>=12.16.0' 'npm' 'ttfautohint')
depends=()
conflicts=(${_pkgname})
provides=(${_pkgname})
-source=(
- 'git+https://github.com/be5invis/Iosevka'
-)
-sha256sums=(
- 'SKIP'
-)
+source=()
+sha256sums=()
-pkgver() {
+prepare () {
+ rm -rf Iosevka
+ git clone --depth 1 --branch master 'https://github.com/be5invis/Iosevka'
+}
+
+pkgver () {
cd Iosevka
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git log -1 --format=%ct
}
-build() {
+build () {
cd Iosevka
npm install
npm update
npm run build -- ttf::${_pkgname#*-}
}
-package() {
+package () {
install -d "${pkgdir}/usr/share/fonts/TTF"
install -m644 Iosevka/dist/*/ttf/*.ttf "${pkgdir}/usr/share/fonts/TTF/"
install -d "${pkgdir}/usr/share/licenses/${pkgname}"