summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNils Czernia2019-02-01 11:37:51 +0100
committerNils Czernia2019-02-01 11:37:51 +0100
commit73097071327e19d1a83673f49afbe1960ef2c926 (patch)
treef3b53543e531e21ce3e49654a8904e21cbb05bdb
parenta21f4d7807502da98bea265a2a6e00d94c5dcd6b (diff)
downloadaur-73097071327e19d1a83673f49afbe1960ef2c926.tar.gz
Added support for arm architectures
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD28
2 files changed, 32 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e182e4d8067f..8cf8c781e333 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,11 +4,20 @@ pkgbase = prometheus-push-gateway-bin
pkgrel = 1
url = https://github.com/prometheus/pushgateway
arch = x86_64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
license = Apache
- source = https://github.com/prometheus/pushgateway/releases/download/v0.7.0/pushgateway-0.7.0.linux-amd64.tar.gz
source = prometheus-push-gateway.service
- sha256sums = 902849c94dc275f157899f7fee1b2f23efbd3bbdb6c3a3c42e503f4439f74ed2
sha256sums = fe0ec9b3f18f2f35177fdf8dd8bd5ef0cee3189b65051b4239ad2ba1f5e9961c
+ source_x86_64 = https://github.com/prometheus/pushgateway/releases/download/v0.7.0/pushgateway-0.7.0.linux-amd64.tar.gz
+ sha256sums_x86_64 = 902849c94dc275f157899f7fee1b2f23efbd3bbdb6c3a3c42e503f4439f74ed2
+ source_arm = https://github.com/prometheus/pushgateway/releases/download/v0.7.0/pushgateway-0.7.0.linux-armv5.tar.gz
+ sha256sums_arm = dbd976ead419b80ff5ac33fa8b766f586c0367160b9e3dc51293f613a8e0e983
+ source_armv6h = https://github.com/prometheus/pushgateway/releases/download/v0.7.0/pushgateway-0.7.0.linux-armv6.tar.gz
+ sha256sums_armv6h = cf41808520e3607b182ad027eba4153ff3b27351461740fdd557a4fc9c590c99
+ source_armv7h = https://github.com/prometheus/pushgateway/releases/download/v0.7.0/pushgateway-0.7.0.linux-armv7.tar.gz
+ sha256sums_armv7h = ff49a6a47efecde2d714ae3732ad115d9c8e36ea171c04b9fbac9573f3c79f49
pkgname = prometheus-push-gateway-bin
diff --git a/PKGBUILD b/PKGBUILD
index d36633cf3d53..8052e751c101 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,16 +4,30 @@ pkgname=prometheus-push-gateway-bin
pkgver=0.7.0
pkgrel=1
pkgdesc="Prometheus push acceptor for ephemeral and batch jobs "
-arch=('x86_64')
+arch=("x86_64" "arm" "armv6h" "armv7h")
url="https://github.com/prometheus/pushgateway"
-license=('Apache')
+license=("Apache")
makedepends=()
-source=("https://github.com/prometheus/pushgateway/releases/download/v${pkgver}/pushgateway-${pkgver}.linux-amd64.tar.gz"
- "prometheus-push-gateway.service")
-sha256sums=('902849c94dc275f157899f7fee1b2f23efbd3bbdb6c3a3c42e503f4439f74ed2'
- 'fe0ec9b3f18f2f35177fdf8dd8bd5ef0cee3189b65051b4239ad2ba1f5e9961c')
+source=("prometheus-push-gateway.service")
+source_x86_64=("https://github.com/prometheus/pushgateway/releases/download/v${pkgver}/pushgateway-${pkgver}.linux-amd64.tar.gz")
+source_arm=("https://github.com/prometheus/pushgateway/releases/download/v${pkgver}/pushgateway-${pkgver}.linux-armv5.tar.gz")
+source_armv6h=("https://github.com/prometheus/pushgateway/releases/download/v${pkgver}/pushgateway-${pkgver}.linux-armv6.tar.gz")
+source_armv7h=("https://github.com/prometheus/pushgateway/releases/download/v${pkgver}/pushgateway-${pkgver}.linux-armv7.tar.gz")
+sha256sums=("fe0ec9b3f18f2f35177fdf8dd8bd5ef0cee3189b65051b4239ad2ba1f5e9961c")
+sha256sums_x86_64=("902849c94dc275f157899f7fee1b2f23efbd3bbdb6c3a3c42e503f4439f74ed2")
+sha256sums_arm=("dbd976ead419b80ff5ac33fa8b766f586c0367160b9e3dc51293f613a8e0e983")
+sha256sums_armv6h=("cf41808520e3607b182ad027eba4153ff3b27351461740fdd557a4fc9c590c99")
+sha256sums_armv7h=("ff49a6a47efecde2d714ae3732ad115d9c8e36ea171c04b9fbac9573f3c79f49")
package() {
- install -Dm755 "${srcdir}/pushgateway-${pkgver}.linux-amd64/pushgateway" "${pkgdir}/usr/bin/prometheus-push-gateway"
+ case "$CARCH" in
+ "x86_64") ARCH="amd64";;
+ "arm") ARCH="armv5";;
+ "armv6h") ARCH="armv6";;
+ "armv7h") ARCH="armv7";;
+ "aarch64") ARCH="arm64";;
+ esac
+
+ install -Dm755 "${srcdir}/pushgateway-${pkgver}.linux-${ARCH}/pushgateway" "${pkgdir}/usr/bin/prometheus-push-gateway"
install -Dm755 "${srcdir}/prometheus-push-gateway.service" "${pkgdir}/usr/lib/systemd/system/prometheus-push-gateway.service"
}