summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesse Jaara2016-10-15 03:09:19 +0300
committerJesse Jaara2016-10-15 03:10:02 +0300
commit73295cc30c94dc640315ac9f6bcca360b38f2cd7 (patch)
treee04fd61b606937973cded639bbab0626462902be
parent962514fc3f80e776dd4b02f34bb71fbd2942cda4 (diff)
downloadaur-73295cc30c94dc640315ac9f6bcca360b38f2cd7.tar.gz
Update to 2.12 and set youtube-dl as default backend.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD19
-rwxr-xr-xyle-dl7
-rw-r--r--yle-dl.install9
4 files changed, 36 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89d33e47c1d7..02af03b1e402 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,22 @@
# Generated by mksrcinfo v8
-# Sun Sep 11 21:57:55 UTC 2016
+# Sat Oct 15 00:08:52 UTC 2016
pkgbase = yle-dl
pkgdesc = Download video and audio from YLE Areena.
- pkgver = 2.11
+ pkgver = 2.12
pkgrel = 1
url = http://aajanki.github.io/yle-dl/
+ install = yle-dl.install
arch = any
license = GPL2
depends = python2-crypto
- depends = php-mcrypt
- optdepends = python2-youtube-dl: new lightweight backend
+ depends = python2-youtube-dl
+ optdepends = php-mcrypt: old PHP backend
optdepends = rtmpdump: old rtmpdump backend
- conflicts = rtmpdump-yle
- replaces = rtmpdump-yle
- source = yle-dl-2.11.tar.gz::https://github.com/aajanki/yle-dl/tarball/2.11
+ source = yle-dl
+ source = yle-dl-2.12.tar.gz::https://github.com/aajanki/yle-dl/tarball/2.12
source = AdobeHDS-2016.05.28.php::https://raw.githubusercontent.com/K-S-V/Scripts/3a9b748f957a921c5f846b3ebc7c99bb8255d2e0/AdobeHDS.php
- md5sums = cd1f167d3165177c03ce90c6f37f15ba
+ md5sums = 1138f597102f6fb4bc43f7dc9a003a3c
+ md5sums = ae31d8963ef4fda8b70b1b34603f0db0
md5sums = 81751f2c5184f33a539b5e0bdfdf7adc
pkgname = yle-dl
diff --git a/PKGBUILD b/PKGBUILD
index 22e9cc3c511d..308811ec1922 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,23 @@
#Maintainer: Jesse Jaara <gmail.com: jesse.jaara>
pkgname=yle-dl
-pkgver=2.11
+pkgver=2.12
pkgrel=1
-_gitid=23c7d98
+_gitid=1261e71
pkgdesc="Download video and audio from YLE Areena."
arch=("any")
url="http://aajanki.github.io/yle-dl/"
license=("GPL2")
-depends=('python2-crypto' 'php-mcrypt')
-optdepends=('python2-youtube-dl: new lightweight backend'
+depends=('python2-crypto' 'python2-youtube-dl')
+optdepends=('php-mcrypt: old PHP backend'
'rtmpdump: old rtmpdump backend')
-conflicts=('rtmpdump-yle')
-replaces=('rtmpdump-yle')
+install=yle-dl.install
_adobehdsversion=2016.05.28
-source=("yle-dl-${pkgver}.tar.gz::https://github.com/aajanki/yle-dl/tarball/${pkgver}"
+source=("yle-dl"
+ "yle-dl-${pkgver}.tar.gz::https://github.com/aajanki/yle-dl/tarball/${pkgver}"
"AdobeHDS-${_adobehdsversion}.php::https://raw.githubusercontent.com/K-S-V/Scripts/3a9b748f957a921c5f846b3ebc7c99bb8255d2e0/AdobeHDS.php")
-md5sums=('cd1f167d3165177c03ce90c6f37f15ba'
+md5sums=('1138f597102f6fb4bc43f7dc9a003a3c'
+ 'ae31d8963ef4fda8b70b1b34603f0db0'
'81751f2c5184f33a539b5e0bdfdf7adc')
prepare() {
@@ -32,4 +33,6 @@ package() {
make prefix=/usr DESTDIR="${pkgdir}" install
install -D -m644 "${srcdir}/AdobeHDS-${_adobehdsversion}.php" "${pkgdir}/usr/share/yle-dl/AdobeHDS.php"
+ install -D -m644 "${srcdir}/aajanki-${pkgname}-${_gitid}/yle-dl" "${pkgdir}/usr/share/yle-dl/yle-dl.py"
+ install -D -m755 "${srcdir}/yle-dl" "${pkgdir}/usr/bin/yle-dl"
}
diff --git a/yle-dl b/yle-dl
new file mode 100755
index 000000000000..1a1fdce745ab
--- /dev/null
+++ b/yle-dl
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+if [ -z "$YLE_DL_BACKEND" ]; then
+ YLE_DL_BACKEND="youtubedl"
+fi
+
+python2 /usr/share/yle-dl/yle-dl.py --backend $YLE_DL_BACKEND $@
diff --git a/yle-dl.install b/yle-dl.install
new file mode 100644
index 000000000000..e25fb68216b9
--- /dev/null
+++ b/yle-dl.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo "Youtube-dl is now used as the default backend."
+ echo "To change back to the PHP one you need to define"
+ echo 'environment variable `YLE_DL_BACKEND=adobehdsphp`.'
+}
+
+post_upgrade() {
+ post_install
+}