summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorProgrammerGrammar2018-11-04 22:15:51 -0600
committerProgrammerGrammar2018-11-04 22:15:51 -0600
commit736ad2714b079f717a31dca0db5d242061ed564d (patch)
tree547901265e945b12908a93411863aa6eb1279127
parentafafd72400e1064716a1db2f812c0f697dec3565 (diff)
downloadaur-736ad2714b079f717a31dca0db5d242061ed564d.tar.gz
added backups
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 431919a46ea2..cdd7785389c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = interactive-diff-patch
- pkgdesc = Allows you to apply diff hunks one at a time and preview them on the command line. Requires diff and patch which are included with git.
- pkgver = 0.0.4
+ pkgdesc = Allows you to apply diff hunks one at a time and preview them on the command line. On Windows this requires diff and patch which are included with git.
+ pkgver = 0.0.5
pkgrel = 1
url = https://gitlab.com/bixfliz/interactive-diff-patch
arch = any
license = MIT
depends = nodejs
depends = npm
- noextract = interactive-diff-patch-0.0.4.tgz
- source = https://registry.npmjs.org/interactive-diff-patch/-/interactive-diff-patch-0.0.4.tgz
- sha1sums = c8f42adaa79cbba789b129559d76115b75daf17a
+ noextract = interactive-diff-patch-0.0.5.tgz
+ source = https://registry.npmjs.org/interactive-diff-patch/-/interactive-diff-patch-0.0.5.tgz
+ sha1sums = 195e961e295e7223226218449b0b7d3da5dcee90
pkgname = interactive-diff-patch
diff --git a/PKGBUILD b/PKGBUILD
index 635e5305eb7b..bff7978f8450 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
_npmname=interactive-diff-patch
-_npmver=0.0.4
+_npmver=0.0.5
pkgname=interactive-diff-patch # All lowercase
-pkgver=0.0.4
+pkgver=0.0.5
pkgrel=1
-pkgdesc="Allows you to apply diff hunks one at a time and preview them on the command line. Requires diff and patch which are included with git."
+pkgdesc="Allows you to apply diff hunks one at a time and preview them on the command line. On Windows this requires diff and patch which are included with git."
arch=(any)
url="https://gitlab.com/bixfliz/interactive-diff-patch"
license=(MIT)
@@ -11,15 +11,14 @@ depends=('nodejs' 'npm')
optdepends=()
source=(https://registry.npmjs.org/$_npmname/-/$_npmname-$_npmver.tgz)
noextract=($_npmname-$_npmver.tgz)
-sha1sums=(c8f42adaa79cbba789b129559d76115b75daf17a)
+sha1sums=(195e961e295e7223226218449b0b7d3da5dcee90)
package() {
cd $srcdir
local _npmdir="$pkgdir/usr/lib/node_modules/"
mkdir -p $_npmdir
cd $_npmdir
- npm install --user root -g --prefix "$pkgdir/usr" $_npmname@$_npmver
-
+ npm install -g --prefix "$pkgdir/usr" $_npmname@$_npmver
find "${pkgdir}"/usr -type d -exec chmod 755 {} +
}