summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilippe Proulx2015-08-15 14:27:47 -0400
committerPhilippe Proulx2015-08-15 14:30:29 -0400
commit7370bc221f45ad2360025eb079c341cdec35d37b (patch)
tree474465f7249d24024290ba44c8a3659425b9274a
downloadaur-7370bc221f45ad2360025eb079c341cdec35d37b.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD21
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4533cd59541c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-colormath
+ pkgdesc = Python module that abstracts common color math operations
+ pkgver = 2.1.1
+ pkgrel = 1
+ url = https://github.com/gtaylor/python-colormath
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python
+ depends = python-networkx
+ depends = python-numpy
+ provides = python-colormath
+ conflicts = python-colormath
+ source = https://github.com/gtaylor/python-colormath/archive/2.1.1.tar.gz
+ md5sums = 77b1b2e053f318069afe6c524ba2d7e8
+
+pkgname = python-colormath
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b37fd0673eb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Philippe Proulx <eeppeliteloop@gmail.com>
+pkgname=python-colormath
+pkgver=2.1.1
+pkgrel=1
+pkgdesc="Python module that abstracts common color math operations"
+arch=('any')
+url="https://github.com/gtaylor/python-colormath"
+license=('GPL3')
+depends=('python' 'python-networkx' 'python-numpy')
+makedepends=('python-setuptools')
+provides=('python-colormath')
+conflicts=('python-colormath')
+source=('https://github.com/gtaylor/python-colormath/archive/2.1.1.tar.gz')
+md5sums=('77b1b2e053f318069afe6c524ba2d7e8')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: