summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuentin Retornaz2017-06-19 17:45:58 +0200
committerQuentin Retornaz2017-06-19 17:45:58 +0200
commit73aa9fcffe35456b16a3feb82a0d03819efb1d21 (patch)
treec947bfcfff4923c7052f85bea03e7a756ecb5510
parent87b04f6c5bf192b563d671af2dabb1df3e8b6373 (diff)
downloadaur-73aa9fcffe35456b16a3feb82a0d03819efb1d21.tar.gz
fix launcher
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb865dec40e4..e7e6a8b0d613 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Jun 19 15:32:04 UTC 2017
+# Mon Jun 19 15:45:42 UTC 2017
pkgbase = firewatch-gog
pkgdesc = Firewatch is a single-player first-person mystery set in the Wyoming wilderness.
pkgver = 1.06_2.4.0.5
- pkgrel = 2
+ pkgrel = 3
url = http://www.redbarrelsgames.com/
arch = x86_64
license = custom: commercial
diff --git a/PKGBUILD b/PKGBUILD
index 1d06580702e0..b063d78df5c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=firewatch-gog
pkgver=1.06_2.4.0.5
_gogver=2.4.0.5
-pkgrel=2
+pkgrel=3
pkgdesc="Firewatch is a single-player first-person mystery set in the Wyoming wilderness."
arch=('x86_64')
url="http://www.redbarrelsgames.com/"
@@ -23,8 +23,10 @@ package() {
# Install Binaries/Launchers
mkdir -p "${pkgdir}/usr/bin"
- ln -s "/opt/firewatch/start.sh" \
- "${pkgdir}/usr/bin/firewatch"
+ cat > "${pkgdir}/usr/bin/firewatch" <<END
+#!/bin/bash
+/opt/firewatch/start.sh
+END
# Desktop Integration
mkdir -p "${pkgdir}/usr/share/pixmaps/"
@@ -35,6 +37,7 @@ package() {
# Permissions
find "${pkgdir}/opt/firewatch" -type d -exec chmod 755 {} \;
find "${pkgdir}/opt/firewatch" -type f -exec chmod 644 {} \;
+ chmod 755 "${pkgdir}/usr/bin/firewatch"
chmod 755 "${pkgdir}/opt/firewatch/start.sh"
chmod 755 "${pkgdir}/opt/firewatch/game/fw.${CARCH}"
}