summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgustawho2021-05-13 20:31:09 -0600
committergustawho2021-05-13 20:31:09 -0600
commit73bc4a5bae0a521786994b14268005b5ef70031f (patch)
tree6e3d3f6443b738882050d2559290f2d286b071a8
parentf6d52955f89e2d2eea47b2b25c339b9e19401d50 (diff)
downloadaur-73bc4a5bae0a521786994b14268005b5ef70031f.tar.gz
PKGBUILD cleanup
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a2437e60d7b..55a5450c1fb9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mauikit-filebrowsing-git
pkgdesc = MauiKit File Browsing utilities and controls
- pkgver = r27.c699485
+ pkgver = v1.2.2.r4.gd6f463e
pkgrel = 1
url = https://invent.kde.org/maui/mauikit-filebrowsing
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 4466b82e38db..29d781b66e2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gustavo Castro < gustawho [ at ] gmail [ dot ] com >
pkgname=mauikit-filebrowsing-git
-pkgver=r27.c699485
+pkgver=v1.2.2.r4.gd6f463e
pkgrel=1
pkgdesc="MauiKit File Browsing utilities and controls"
arch=(x86_64 i686 arm armv6h armv7h aarch64)
@@ -23,10 +23,10 @@ pkgver() {
}
build() {
- cmake -DCMAKE_INSTALL_PREFIX=/usr -B build -S "${pkgname%-git}"
- make -C build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=RelWithDebInfo -B build -S "${pkgname%-git}"
+ cmake --build build --config RelWithDebInfo
}
package() {
- make -C build DESTDIR="${pkgdir}" PREFIX=/usr install
-}
+ DESTDIR="${pkgdir}" cmake --install build --config RelWithDebInfo
+} \ No newline at end of file