summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTérence Clastres2020-06-20 18:01:15 +0200
committerTérence Clastres2020-06-20 18:01:15 +0200
commit740f9ed7a0c5806c3b97f82170f53ef1fc5b0d01 (patch)
tree17012ca3be686e72b8396e49b3f52e6e0446c063
parent58b3837e153acd9d8492ecffb11ca901d4a5a766 (diff)
downloadaur-740f9ed7a0c5806c3b97f82170f53ef1fc5b0d01.tar.gz
Fix build
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD27
-rw-r--r--giada-git-devendor_nlohmann-json.patch55
3 files changed, 94 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 010ea14e1b72..472bab6ad31d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,31 +1,51 @@
pkgbase = giada-git
pkgdesc = A free, minimal, hardcore audio tool for DJs, live performers and electronic musicians
- pkgver = v0.16.2.r0.ga042f4a1
- pkgrel = 2
+ pkgver = v0.16.3.r10.g3dc97d07
+ pkgrel = 1
url = https://www.giadamusic.com/
arch = x86_64
groups = pro-audio
license = GPL3
checkdepends = catch2
+ checkdepends = xorg-server-xvfb
+ makedepends = alsa-lib
makedepends = gendesk
makedepends = imagemagick
+ makedepends = jack
+ makedepends = libpulse
+ makedepends = libsamplerate
+ makedepends = libsndfile
+ makedepends = nlohmann-json
+ makedepends = rtmidi
depends = fltk
- depends = jansson
- depends = libpulse
+ depends = gcc-libs
+ depends = glibc
+ depends = libx11
depends = libxpm
- depends = rtmidi
conflicts = giada
conflicts = giada-vst
source = giada-git::git+https://github.com/monocasual/giada.git
- source = git+https://github.com/monocasual/rtaudio.git
+ source = giada-git-devendor_nlohmann-json.patch
source = JUCE-5.3.2.tar.gz::https://github.com/WeAreROLI/JUCE/archive/5.3.2.tar.gz
source = https://raw.githubusercontent.com/nlohmann/json/bde57124187c5732c026ffb9357c0491344c45e7/single_include/nlohmann/json.hpp
source = gcc9-fix.diff
sha512sums = SKIP
- sha512sums = SKIP
+ sha512sums = 31cf5b2b1bba29e8c97109c04c6456a98b778017ef5d48a0f020d326d8a11a5e76c8613fc232a2492d16aa48bc2faaae4aae7316252d6b887bd2187032fb83f9
sha512sums = f968a622306e12542c0971fd4cac5c311d70304d63fef8a177e8624a3f43916254122cf5d068974bf062a59d95fd6df97400a3d2ff950b117399cc667b976b9d
sha512sums = a3bdd5dc53097584bf2bbe19f296b1726b9fa751905bae22990dc9eb17015e49e1911956b1e29dbaacbe6c285100a653179c191f223b6e612be633505347c34c
sha512sums = 0b011913f031930d3540daf2bec8df66b345f59c79d1666a6447f5b1be0b0e59cfd855bd6ec581118cd6949f24aba8e4c503ad73f0fe5a4bb1882b60ed3cd41f
pkgname = giada-git
+ depends = fltk
+ depends = gcc-libs
+ depends = glibc
+ depends = libx11
+ depends = libxpm
+ depends = libasound.so
+ depends = libjack.so
+ depends = libpulse.so
+ depends = libpulse-simple.so
+ depends = librtmidi.so
+ depends = libsamplerate.so
+ depends = libsndfile.so
diff --git a/PKGBUILD b/PKGBUILD
index 004084511a55..8bf25764c3ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,25 @@
# Maintainer: Térence Clastres <t.clastres@gmail.com>
pkgname=giada-git
-pkgver=v0.16.2.r0.ga042f4a1
-pkgrel=2
+pkgver=v0.16.3.r10.g3dc97d07
+pkgrel=1
pkgdesc="A free, minimal, hardcore audio tool for DJs, live performers and electronic musicians"
arch=('x86_64')
url="https://www.giadamusic.com/"
license=('GPL3')
groups=('pro-audio')
-depends=('fltk' 'jansson' 'libpulse' 'libxpm' 'rtmidi')
-makedepends=('gendesk' 'imagemagick')
-checkdepends=('catch2')
+depends=('fltk' 'gcc-libs' 'glibc' 'libx11' 'libxpm')
+makedepends=('alsa-lib' 'gendesk' 'imagemagick' 'jack' 'libpulse' 'libsamplerate' 'libsndfile' 'nlohmann-json' 'rtmidi')
+checkdepends=('catch2' 'xorg-server-xvfb')
conflicts=('giada' 'giada-vst')
source=("giada-git::git+https://github.com/monocasual/giada.git"
- "git+https://github.com/monocasual/rtaudio.git"
+ "$pkgname-devendor_nlohmann-json.patch"
"JUCE-5.3.2.tar.gz::https://github.com/WeAreROLI/JUCE/archive/5.3.2.tar.gz"
"https://raw.githubusercontent.com/nlohmann/json/bde57124187c5732c026ffb9357c0491344c45e7/single_include/nlohmann/json.hpp"
"gcc9-fix.diff"
)
sha512sums=('SKIP'
- 'SKIP'
+ '31cf5b2b1bba29e8c97109c04c6456a98b778017ef5d48a0f020d326d8a11a5e76c8613fc232a2492d16aa48bc2faaae4aae7316252d6b887bd2187032fb83f9'
'f968a622306e12542c0971fd4cac5c311d70304d63fef8a177e8624a3f43916254122cf5d068974bf062a59d95fd6df97400a3d2ff950b117399cc667b976b9d'
'a3bdd5dc53097584bf2bbe19f296b1726b9fa751905bae22990dc9eb17015e49e1911956b1e29dbaacbe6c285100a653179c191f223b6e612be633505347c34c'
'0b011913f031930d3540daf2bec8df66b345f59c79d1666a6447f5b1be0b0e59cfd855bd6ec581118cd6949f24aba8e4c503ad73f0fe5a4bb1882b60ed3cd41f')
@@ -35,8 +35,6 @@ prepare() {
cp -r ../JUCE-5.3.2/modules/ src/deps/juce/
patch -p2 -i ../../../../../gcc9-fix.diff -d src/deps/juce/modules/
- mkdir -p src/deps/json/single_include/nlohmann/ && cp ../json.hpp src/deps/json/single_include/nlohmann/
-
autoreconf -vfi
# XDG desktop file
gendesk -n -f \
@@ -45,17 +43,15 @@ prepare() {
--name Giada \
--categories "AudioVideo;Audio;Midi;Sequencer"
- # fixing catch2 include for system library
+ # fixing catch2 include for system library
sed -e 's|catch\.hpp|catch2/catch\.hpp|g' -i tests/*.cpp
-
- git submodule init src/deps/rtaudio
- git config submodule.src/deps/rtaudio.url $srcdir/rtaudio
- git submodule update
-
+ # devendor nlohmann-json
+ patch -Np1 -i ../"$pkgname-devendor_nlohmann-json.patch"
}
build() {
cd "$pkgname"
+
./configure --prefix=/usr \
--target=linux \
--enable-vst \
@@ -70,6 +66,7 @@ check() {
}
package() {
+ depends+=('libasound.so' 'libjack.so' 'libpulse.so' 'libpulse-simple.so' 'librtmidi.so' 'libsamplerate.so' 'libsndfile.so')
cd "$pkgname"
make DESTDIR="$pkgdir/" install
# XDG integration
diff --git a/giada-git-devendor_nlohmann-json.patch b/giada-git-devendor_nlohmann-json.patch
new file mode 100644
index 000000000000..124b20c94f3e
--- /dev/null
+++ b/giada-git-devendor_nlohmann-json.patch
@@ -0,0 +1,55 @@
+diff -ruN a/src/core/conf.cpp b/src/core/conf.cpp
+--- a/src/core/conf.cpp 2020-02-18 22:26:06.000000000 +0100
++++ b/src/core/conf.cpp 2020-02-20 20:00:59.845504376 +0100
+@@ -29,7 +29,7 @@
+ #include <cassert>
+ #include <string>
+ #include <FL/Fl.H>
+-#include "deps/json/single_include/nlohmann/json.hpp"
++#include <nlohmann/json.hpp>
+ #include "utils/fs.h"
+ #include "utils/log.h"
+ #include "core/const.h"
+@@ -314,4 +314,4 @@
+ ofs << j;
+ return true;
+ }
+-}}}; // giada::m::conf::
+\ No newline at end of file
++}}}; // giada::m::conf::
+diff -ruN a/src/core/init.cpp b/src/core/init.cpp
+--- a/src/core/init.cpp 2020-02-18 22:26:06.000000000 +0100
++++ b/src/core/init.cpp 2020-02-20 19:59:55.206135824 +0100
+@@ -35,7 +35,7 @@
+ #include <X11/Xlib.h> // For XInitThreads
+ #endif
+ #include <FL/Fl.H>
+-#include "deps/json/single_include/nlohmann/json.hpp"
++#include <nlohmann/json.hpp>
+ #include "gui/updater.h"
+ #include "utils/log.h"
+ #include "utils/fs.h"
+diff -ruN a/src/core/midiMapConf.cpp b/src/core/midiMapConf.cpp
+--- a/src/core/midiMapConf.cpp 2020-02-18 22:26:06.000000000 +0100
++++ b/src/core/midiMapConf.cpp 2020-02-20 20:01:20.878632255 +0100
+@@ -30,7 +30,7 @@
+ #include <string>
+ #include <cstring>
+ #include <dirent.h>
+-#include "deps/json/single_include/nlohmann/json.hpp"
++#include <nlohmann/json.hpp>
+ #include "utils/string.h"
+ #include "utils/log.h"
+ #include "utils/fs.h"
+diff -ruN a/src/core/patch.cpp b/src/core/patch.cpp
+--- a/src/core/patch.cpp 2020-02-18 22:26:06.000000000 +0100
++++ b/src/core/patch.cpp 2020-02-20 20:00:40.602359018 +0100
+@@ -26,7 +26,7 @@
+
+
+ #include <fstream>
+-#include "deps/json/single_include/nlohmann/json.hpp"
++#include <nlohmann/json.hpp>
+ #include "utils/math.h"
+ #include "utils/log.h"
+ #include "core/mixer.h"