summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJerome Leclanche2015-06-09 23:17:17 +0200
committerJerome Leclanche2015-06-09 23:17:17 +0200
commit742f662a5176a63378709baa8ddab2078d20ea37 (patch)
treec2de78c1f5b7ebdc612e55d839e49ec6a8980884
downloadaur-742f662a5176a63378709baa8ddab2078d20ea37.tar.gz
Initial import from old AUR
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0d7282c05580
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-polib
+ pkgdesc = A library to manipulate, create and modify gettext files
+ pkgver = 1.0.6
+ pkgrel = 1
+ url = https://bitbucket.org/izi/polib/
+ arch = any
+ license = MIT
+ depends = python
+ source = https://pypi.python.org/packages/source/p/polib/polib-1.0.6.tar.gz
+ md5sums = 2369620208823811a89a2da73ed606c9
+ sha256sums = 20d2a0d589a692c11df549bd7cda83c665eef2a83e017b843fecdf956edbad74
+
+pkgname = python-polib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f5a8103cca07
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Jerome Leclanche <jerome@leclan.ch>
+
+_pkgname=polib
+pkgname=python-$_pkgname
+pkgver=1.0.6
+pkgrel=1
+pkgdesc="A library to manipulate, create and modify gettext files"
+url="https://bitbucket.org/izi/polib/"
+arch=("any")
+license=("MIT")
+depends=("python")
+source=("https://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+md5sums=("2369620208823811a89a2da73ed606c9")
+sha256sums=("20d2a0d589a692c11df549bd7cda83c665eef2a83e017b843fecdf956edbad74")
+
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}