summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgéballin2019-05-15 16:43:21 +0200
committergéballin2019-05-15 16:43:21 +0200
commit744b75fe8dda6d80887d032b4c7db1faa6a6e05f (patch)
tree49cd9fbc86696cdaf04c6a3d88a2855c81f37d87
downloadaur-744b75fe8dda6d80887d032b4c7db1faa6a6e05f.tar.gz
Initial commit of version 0.1
-rw-r--r--.SRCINFO19
-rwxr-xr-xPKGBUILD29
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..98ccb4d239cd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = mdliveview
+ pkgdesc = Mdliveview is a lightweight Markdown file viewer with autoreload
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/Geballin/Mdliveview
+ arch = x86_64
+ arch = i686
+ license = BSD
+ makedepends = make
+ makedepends = gcc
+ depends = tcl
+ depends = tk
+ depends = gifblock
+ depends = tkhtml
+ source = https://github.com/Geballin/Mdliveview/archive/0.1.tar.gz
+ md5sums = 9ea267e491da0229681c821ccf60c90f
+
+pkgname = mdliveview
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..2956153115e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Geballin - Guillaume Ballin <macniaque at free dot fr>
+pkgname=mdliveview
+pkgver=0.1
+pkgrel=1
+pkgdesc="Mdliveview is a lightweight Markdown file viewer with autoreload"
+url="https://github.com/Geballin/Mdliveview"
+arch=('x86_64' 'i686')
+license=('BSD')
+depends=('tcl' 'tk' 'gifblock' 'tkhtml')
+optdepends=()
+makedepends=(make gcc)
+conflicts=()
+replaces=()
+backup=()
+install=
+source=("https://github.com/Geballin/Mdliveview/archive/${pkgver}.tar.gz")
+
+md5sums=(9ea267e491da0229681c821ccf60c90f)
+
+build() {
+ cd ${srcdir}/Mdliveview-${pkgver}
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${srcdir}/Mdliveview-${pkgver}
+ make DESTDIR="${pkgdir}" install
+}