summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12020-09-21 20:41:03 +0800
committerChocobo12020-09-21 21:00:30 +0800
commit744f49879e224a9e46b9a7db13676e79a3526913 (patch)
treee45a47ea3a22b9f5a39909992132cb6a08aa01b3
parent351f4a2a8e7101e11a36fb1210ea2dec8b772834 (diff)
downloadaur-744f49879e224a9e46b9a7db13676e79a3526913.tar.gz
upgpkg: openssl-git 3.0.0.alpha6.r483.g6600baa9bb-1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f87f73dae65..bfd67284631c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = openssl-git
pkgdesc = Toolkit for the Transport Layer Security (TLS) and Secure Sockets Layer (SSL) protocols
- pkgver = 1.1.1.r2775.g30a4cda5e0
- pkgrel = 2
+ pkgver = 3.0.0.alpha6.r483.g6600baa9bb
+ pkgrel = 1
url = https://www.openssl.org/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index f995818c2cee..e6a45fa7ac6d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Pierre Schmitz <pierre@archlinux.de>
pkgname=openssl-git
-pkgver=1.1.1.r2775.g30a4cda5e0
-pkgrel=2
+pkgver=3.0.0.alpha6.r483.g6600baa9bb
+pkgrel=1
pkgdesc="Toolkit for the Transport Layer Security (TLS) and Secure Sockets Layer (SSL) protocols"
arch=('i686' 'x86_64')
url="https://www.openssl.org/"
@@ -25,13 +25,13 @@ sha256sums=('SKIP'
prepare() {
cd "openssl"
- patch -Np0 -i "$srcdir/ca-dir.patch"
+ patch -Np0 -F100 -i "$srcdir/ca-dir.patch"
}
pkgver() {
cd "openssl"
- git describe --long --tags | sed 's/^OpenSSL_//;s/\([^-]*-g\)/r\1/;s/-/./g;s/_/./g'
+ git describe --long --tags | sed 's/^OpenSSL[_-]//I;s/\([^-]*-g\)/r\1/;s/-/./g;s/_/./g'
}
build() {
@@ -48,7 +48,8 @@ build() {
--libdir="lib" \
--openssldir="/etc/ssl" \
"$_target" \
- "-Wa,--noexecstack $CPPFLAGS $CFLAGS $LDFLAGS"
+ "-Wa,--noexecstack $CPPFLAGS $CFLAGS $LDFLAGS" \
+ shared
make depend
make
}
@@ -58,9 +59,10 @@ check() {
# the test fails due to missing write permissions in /etc/ssl
# revert this patch for make test
- #patch -Np0 -R -i "$srcdir/ca-dir.patch"
+ #patch -Np0 -F100 -R -i "$srcdir/ca-dir.patch"
#make test
- #patch -Np0 -i "$srcdir/ca-dir.patch"
+ #patch -Np0 -F100 -i "$srcdir/ca-dir.patch"
+ #make apps/CA.pl
}
package() {