summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2022-03-19 15:12:37 +0100
committerMichel Zou2022-03-19 15:12:37 +0100
commit74514e34a9c6c8558f631b9914b32f0dd8899d0a (patch)
treebc8fcb1a912034fec1d5d04f40e918e63b8f8b45
parentfd50154b4150734057711b80125d8f069f784114 (diff)
downloadaur-74514e34a9c6c8558f631b9914b32f0dd8899d0a.tar.gz
2.4.0rc1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD21
2 files changed, 8 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3487cb628a81..c8da41ba8cb5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-pdal
pkgdesc = A C++ library for translating and manipulating point cloud data (mingw-w64)
- pkgver = 2.3.0
+ pkgver = 2.4.0
pkgrel = 1
url = http://www.pdal.io
arch = any
@@ -8,7 +8,6 @@ pkgbase = mingw-w64-pdal
makedepends = mingw-w64-cmake
depends = mingw-w64-gdal
depends = mingw-w64-libgeotiff
- depends = mingw-w64-laszip
depends = mingw-w64-jsoncpp
depends = mingw-w64-hexer-hobu
depends = mingw-w64-postgresql-libs
@@ -16,7 +15,7 @@ pkgbase = mingw-w64-pdal
options = !buildflags
options = staticlibs
options = !strip
- source = https://github.com/PDAL/PDAL/releases/download/2.3.0/PDAL-2.3.0-src.tar.gz
- sha512sums = 9de87de7370175e76b95d3ec08667eb28b90a63eed8133f144427ff931e575d1f37aa13496f12054577539ee552458475dd054bcbdedfabe52eb0e32c4483d05
+ source = https://github.com/PDAL/PDAL/releases/download/2.4.0RC1/PDAL-2.4.0RC1-src.tar.gz
+ sha256sums = ad4502edeb1b39a57308126396a67e936896dcca500c143023137ef588c8098f
pkgname = mingw-w64-pdal
diff --git a/PKGBUILD b/PKGBUILD
index bc18b9da7a2c..f2f986b37ac8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,20 @@
pkgname=mingw-w64-pdal
-pkgver=2.3.0
+pkgver=2.4.0
pkgrel=1
pkgdesc="A C++ library for translating and manipulating point cloud data (mingw-w64)"
arch=('any')
url="http://www.pdal.io"
license=('BSD')
-depends=('mingw-w64-gdal' 'mingw-w64-libgeotiff' 'mingw-w64-laszip' 'mingw-w64-jsoncpp' 'mingw-w64-hexer-hobu' 'mingw-w64-postgresql-libs' 'mingw-w64-sqlite')
+depends=('mingw-w64-gdal' 'mingw-w64-libgeotiff' 'mingw-w64-jsoncpp' 'mingw-w64-hexer-hobu' 'mingw-w64-postgresql-libs' 'mingw-w64-sqlite')
makedepends=('mingw-w64-cmake')
options=('!buildflags' 'staticlibs' '!strip')
-source=("https://github.com/PDAL/PDAL/releases/download/${pkgver}/PDAL-${pkgver}-src.tar.gz")
-sha512sums=('9de87de7370175e76b95d3ec08667eb28b90a63eed8133f144427ff931e575d1f37aa13496f12054577539ee552458475dd054bcbdedfabe52eb0e32c4483d05')
+source=("https://github.com/PDAL/PDAL/releases/download/${pkgver}RC1/PDAL-${pkgver}RC1-src.tar.gz")
+sha256sums=('ad4502edeb1b39a57308126396a67e936896dcca500c143023137ef588c8098f')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd "PDAL-$pkgver-src/"
- sed -i "s|get_git_head_revision|#|g" CMakeLists.txt
- curl -L https://github.com/PDAL/PDAL/pull/3507.patch | patch -p1
- curl -L https://github.com/PDAL/PDAL/pull/3508.patch | patch -p1
- curl -L https://github.com/PDAL/PDAL/pull/3509.patch | patch -p1
- curl -L https://github.com/PDAL/PDAL/pull/3511.patch | patch -p1
- curl -L https://github.com/PDAL/PDAL/pull/3512.patch | patch -p1
- curl -L https://github.com/PDAL/PDAL/pull/3513.patch | patch -p1
- curl -L https://github.com/PDAL/PDAL/pull/3514.patch | patch -p1
- curl -L https://github.com/PDAL/PDAL/pull/3515.patch | patch -p1
- curl -L https://github.com/PDAL/PDAL/pull/3516.patch | patch -p1
}
build() {
@@ -33,8 +23,6 @@ build() {
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-cmake -DWITH_TESTS=OFF \
-DBUILD_PLUGIN_PGPOINTCLOUD=ON \
- -DWITH_LAZPERF=ON \
- -DWITH_LASZIP=ON \
-DWITH_COMPLETION=ON ..
make
popd
@@ -46,6 +34,7 @@ package() {
cd "$srcdir/PDAL-${pkgver}-src/build-${_arch}"
make install DESTDIR="$pkgdir"
rm "$pkgdir"/usr/${_arch}/bin/*.exe
+ rm -r "$pkgdir"/usr/${_arch}/share
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
done