summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWorMzy Tykashi2015-06-12 22:59:22 +0100
committerWorMzy Tykashi2015-06-12 22:59:22 +0100
commit745bbef26a1a9b36f8dafca69d6eb06339f3f3fe (patch)
treec0d60b0072d96c144c455160568678b425730d57
downloadaur-745bbef26a1a9b36f8dafca69d6eb06339f3f3fe.tar.gz
Copied from non-git
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD38
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5162aa67c715
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = transmission-remote-cli-git
+ pkgdesc = Curses interface for the daemon of the BitTorrent client Transmission
+ pkgver = 1.7.0.49.g62de9f0
+ pkgrel = 1
+ url = https://github.com/fagga/transmission-remote-cli
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python2
+ optdepends = python2-geoip: Guess which country peers come from
+ optdepends = adns-python: Resolve IPs to host names
+ conflicts = transmission-remote-cli
+ replaces = transmission-remote-cli
+ source = git+https://github.com/fagga/transmission-remote-cli.git
+ md5sums = SKIP
+
+pkgname = transmission-remote-cli-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf456a3c8c83
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: WorMzy Tykashi <wormzy.tykashi@gmail.com>
+# Contributer: fauno <fauno@kiwwwi.com.ar>
+# Contributor: SanskritFritz
+
+pkgname=transmission-remote-cli-git
+_gitname=${pkgname%-git}
+pkgver=1.7.0.49.g62de9f0
+pkgrel=1
+pkgdesc="Curses interface for the daemon of the BitTorrent client Transmission"
+arch=('any')
+url="https://github.com/fagga/transmission-remote-cli"
+license=('GPL3')
+depends=('python2')
+makedepends=('git')
+conflicts=('transmission-remote-cli')
+replaces=('transmission-remote-cli')
+optdepends=('python2-geoip: Guess which country peers come from'
+ 'adns-python: Resolve IPs to host names')
+source=("git+https://github.com/fagga/transmission-remote-cli.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_gitname"
+ git --no-pager describe --tags | sed -e 's:-:.:g' -e '1s:v::'
+}
+
+prepare() {
+ cd "$_gitname"
+ sed -i "1s/python/python2/" transmission-remote-cli
+}
+
+package() {
+ cd "$_gitname"
+
+ install -D -m755 "transmission-remote-cli" "${pkgdir}/usr/bin/transmission-remote-cli"
+ install -D -m644 "transmission-remote-cli.1" "${pkgdir}/usr/share/man/man1/transmission-remote-cli.1"
+ install -D -m755 "completion/bash/transmission-remote-cli-bash-completion.sh" "${pkgdir}/etc/bash_completion.d/transmission-remote-cli-bash-completion.sh"
+}