summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBert Peters2018-12-29 11:00:14 +0100
committerBert Peters2018-12-29 11:00:14 +0100
commit7464a5736ee375984a4feda0376278ea82c3e59a (patch)
tree2847b42fdef46b2323b8d07a664900f7b744169d
downloadaur-7464a5736ee375984a4feda0376278ea82c3e59a.tar.gz
Initial package.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD51
-rw-r--r--cuda.patch32
3 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b21e4efafd58
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = hashclash-git
+ pkgdesc = Project HashClash - MD5 & SHA-1 cryptanalysis
+ pkgver = r45.c1159e9
+ pkgrel = 1
+ url = https://github.com/cr-marcstevens/hashclash
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = boost
+ depends = boost-libs
+ provides = hashclash
+ conflicts = hashclash
+ source = hashclash::git+https://github.com/cr-marcstevens/hashclash
+ source = cuda.patch
+ md5sums = SKIP
+ md5sums = e50c821804f404ed10ccecc790382f8f
+
+pkgname = hashclash-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b540f1136e5e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# The following guidelines are specific to BZR, GIT, HG and SVN packages.
+# Other VCS sources are not natively supported by makepkg yet.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=hashclash-git
+pkgver=r45.c1159e9
+pkgrel=1
+pkgdesc="Project HashClash - MD5 & SHA-1 cryptanalysis "
+arch=(x86_64)
+url="https://github.com/cr-marcstevens/hashclash"
+license=('GPL')
+depends=(boost-libs)
+makedepends=('git' 'boost')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("${pkgname%-git}::git+https://github.com/cr-marcstevens/hashclash"
+ "cuda.patch")
+md5sums=('SKIP'
+ 'e50c821804f404ed10ccecc790382f8f')
+
+# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ patch -p1 < "$srcdir/cuda.patch"
+}
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+
+# Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ autoreconf --install
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/cuda.patch b/cuda.patch
new file mode 100644
index 000000000000..a18d797914a3
--- /dev/null
+++ b/cuda.patch
@@ -0,0 +1,32 @@
+diff --git a/m4/ax_cuda.m4 b/m4/ax_cuda.m4
+index f9d9f8e..82646b0 100644
+--- a/m4/ax_cuda.m4
++++ b/m4/ax_cuda.m4
+@@ -88,17 +88,9 @@ then
+ # test if nvcc version is >= 2.3
+ NVCC_VERSION=`$NVCC --version | grep release | awk 'gsub(/,/, "") {print [$]5}'`
+ AC_MSG_RESULT([nvcc version : $NVCC_VERSION])
+-
++
+ # test if architecture is 64 bits and NVCC version >= 2.3
+ libdir=lib
+- AX_COMPARE_VERSION([$NVCC_VERSION],[gt],[2.2],[
+- if test "x$host_cpu" = xx86_64 ; then
+- libdir=lib64
+- fi
+- if test "x$host_cpu" = xpowerpc64le ; then
+- libdir=lib64
+- fi
+- ])
+
+ # set CUDA flags
+ if test -n "$cuda_home_path"
+@@ -163,7 +155,7 @@ then
+
+ CPPFLAGS=$saved_CPPFLAGS
+ LIBS=$saved_LIBS
+-fi
++fi
+
+ have_cuda="no"
+ if test "$want_cuda" != "no" -a "$have_cuda_headers" = "yes" -a "$have_cuda_libs" = "yes" -a "$have_nvcc" = "yes"