summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-06-03 14:04:29 -0700
committerxiota2023-06-03 14:08:49 -0700
commit746f7ae4eb4a8f7a21296c04fc54030c8faacc99 (patch)
treec73ea3f548d4f3c00f08bda55bddf40688ec08e1
parent45fd77a634a36b24afea502fda319be540be5fa0 (diff)
downloadaur-746f7ae4eb4a8f7a21296c04fc54030c8faacc99.tar.gz
update build/package
-rw-r--r--PKGBUILD10
1 files changed, 2 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6e54c61b793b..3f83db93ef5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,3 +1,4 @@
+# Maintainer:
# Contributor: xiretza <xiretza+aur@gmail.com>
# Contributor: getzze <getzze at gmail dot com>
@@ -26,6 +27,7 @@ checkdepends=(
'python-pytest'
'python-pytest-mock'
)
+
source=(
"$_pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
)
@@ -36,17 +38,10 @@ sha256sums=(
prepare() {
cd "$srcdir/$_pkgname-$pkgver"
sed -i -e 's/collections.Iterable/collections.abc.Iterable/g' ffmpeg/_run.py
-
- for p in "$srcdir"/*.patch ; do
- if [ -e "$p" ] ; then
- patch -Np1 -F100 -i "$p"
- fi
- done
}
build() {
cd "$srcdir/$_pkgname-$pkgver"
- #python setup.py build
python -m build --no-isolation --wheel
}
@@ -57,6 +52,5 @@ check(){
package() {
cd "$srcdir/$_pkgname-$pkgver"
- #python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
python -m installer --destdir="$pkgdir" dist/*.whl
}