summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmmanuel Gil Peyrot2021-11-13 18:26:32 +0100
committerEmmanuel Gil Peyrot2021-11-13 18:30:37 +0100
commit74815f03e00d5a91e9e18af22830d680d0ed223f (patch)
tree2edb61f13cf8e014a33d0c472a8197064092bdf9
parent1596b356389b941e3eb87b8ddd13f437b3e690d9 (diff)
downloadaur-74815f03e00d5a91e9e18af22830d680d0ed223f.tar.gz
Use split packages, now that there are two repositories
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD57
2 files changed, 48 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 292548059c1b..9433e94c6abc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,17 @@
pkgbase = play.it-git
- pkgdesc = Easy way to install games on Linux - git version
- pkgver = 2.11.3.r77.gefb6330b
+ pkgver = r3072.bbf6b17e
pkgrel = 1
url = https://wiki.dotslashplay.it
arch = any
license = BSD
makedepends = pandoc
+ source = git+https://forge.dotslashplay.it/play.it/scripts.git
+ source = git+https://forge.dotslashplay.it/play.it/games.git
+ sha1sums = SKIP
+ sha1sums = SKIP
+
+pkgname = play.it-git
+ pkgdesc = Easy way to install games on Linux - git version
depends = bash
optdepends = imagemagick: to convert images between formats
optdepends = libarchive: to extract various archive formats
@@ -14,8 +20,9 @@ pkgbase = play.it-git
optdepends = unzip: to extract some archives
provides = play.it
conflicts = play.it
- source = play.it::git+https://forge.dotslashplay.it/play.it/scripts.git
- sha1sums = SKIP
-
-pkgname = play.it-git
+pkgname = play.it-games-git
+ pkgdesc = Easy way to install games on Linux, game scripts - git version
+ depends = play.it-git
+ provides = play.it-games
+ conflicts = play.it-games
diff --git a/PKGBUILD b/PKGBUILD
index ee829f3648b8..ada2506e7278 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,58 @@
# Maintainer: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
# Contributor: Mopi <mopi@dotslashplay.it>
-pkgname=play.it-git
-pkgver=2.11.3.r77.gefb6330b
+pkgbase=play.it-git
+pkgname=(play.it-git play.it-games-git)
+pkgver=r3072.bbf6b17e
pkgrel=1
-pkgdesc="Easy way to install games on Linux - git version"
arch=('any')
url="https://wiki.dotslashplay.it"
license=('BSD')
-depends=('bash')
makedepends=('pandoc')
-provides=('play.it')
-conflicts=('play.it')
-optdepends=(
- 'imagemagick: to convert images between formats'
- 'libarchive: to extract various archive formats'
- 'icoutils: to manipulate Windows icon files'
- 'innoextract: to extract some Windows installers'
- 'unzip: to extract some archives'
-)
-source=(play.it::"git+https://forge.dotslashplay.it/play.it/scripts.git")
-sha1sums=('SKIP')
+source=('git+https://forge.dotslashplay.it/play.it/scripts.git'
+ 'git+https://forge.dotslashplay.it/play.it/games.git')
+sha1sums=('SKIP' 'SKIP')
pkgver() {
- cd play.it
+ cd scripts
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd play.it
- sed -i '/DEFAULT_OPTION_PREFIX/s,=.*,=/usr,' play.it-2/src/99_init.sh
+ cd scripts
+ sed -i '/^\s\+DEFAULT_OPTION_ARCHITECTURE=/s,=.*,=auto,' play.it-2/src/99_init.sh
}
build() {
- cd play.it
+ cd scripts
make
}
-package() {
- cd play.it
- make DESTDIR="$pkgdir"/ prefix=/usr bindir=/usr/bin datadir=/usr/share install
+package_play.it-git() {
+ pkgdesc="Easy way to install games on Linux - git version"
+ depends=('bash')
+ optdepends=(
+ 'imagemagick: to convert images between formats'
+ 'libarchive: to extract various archive formats'
+ 'icoutils: to manipulate Windows icon files'
+ 'innoextract: to extract some Windows installers'
+ 'unzip: to extract some archives'
+ )
+ provides=('play.it')
+ conflicts=('play.it')
+
+ cd scripts
+ make DESTDIR="$pkgdir"/ prefix=/usr bindir=/usr/bin datadir=/usr/share install-library install-wrapper install-manpage
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
+package_play.it-games-git() {
+ pkgdesc="Easy way to install games on Linux, game scripts - git version"
+ depends=('play.it-git')
+ provides=('play.it-games')
+ conflicts=('play.it-games')
+
+ cd games
+ make DESTDIR="$pkgdir"/ prefix=/usr bindir=/usr/bin datadir=/usr/share install
+}
+