summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRubenKelevra2022-05-17 23:39:55 +0200
committerRubenKelevra2022-05-17 23:39:55 +0200
commit7494318a7fdba8ddb51ed207a53ff76543c1c3f9 (patch)
tree5a58c77654f43a0b5f6f0d180ab8fb040c40c9a6
parentdddf85ee90a99f3f744299cc90262c7a00955f5a (diff)
downloadaur-7494318a7fdba8ddb51ed207a53ff76543c1c3f9.tar.gz
fix cpu feature level detection for x86_64 v3/v2
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f0d8877dc51..2ddd3e5a54f6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = go-ipfs-git
pkgdesc = A peer-to-peer hypermedia distribution protocol
pkgver = latest
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://github.com/ipfs/go-ipfs
install = go-ipfs-git.install
diff --git a/PKGBUILD b/PKGBUILD
index 8656fc53dfc0..096aac9aaa2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ DEBUG=0
_pkgname=go-ipfs
pkgname=$_pkgname-git
pkgver=latest
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc='A peer-to-peer hypermedia distribution protocol'
@@ -104,8 +104,8 @@ build() {
if [ "$CARCH" == "x86_64" ] && [ -z "$GOAMD64" ]; then
# detect cpu feature level
version_4="$(/lib/ld-linux-x86-64.so.2 --help | grep supported | grep x86-64-v4 | wc -l)"
- version_3="$(/lib/ld-linux-x86-64.so.2 --help | grep supported | grep x86-64-v4 | wc -l)"
- version_2="$(/lib/ld-linux-x86-64.so.2 --help | grep supported | grep x86-64-v4 | wc -l)"
+ version_3="$(/lib/ld-linux-x86-64.so.2 --help | grep supported | grep x86-64-v3 | wc -l)"
+ version_2="$(/lib/ld-linux-x86-64.so.2 --help | grep supported | grep x86-64-v2 | wc -l)"
if [ "$version_4" -gt 0 ]; then
export GOAMD64="v4"