summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2021-08-12 10:12:43 +0200
committerXZS2022-09-13 14:08:14 +0200
commit74ac9e86163104eea6f4a5ce5e5f3dba03484340 (patch)
tree0a89ac91475842007e1052947f0d0ea0f2d0a78d
parent538aef3dfe0e5f8da3603c147dbfb0c43400c4db (diff)
downloadaur-74ac9e86163104eea6f4a5ce5e5f3dba03484340.tar.gz
fix --mirror option
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--tllocalmgr-mirror-opt.patch13
3 files changed, 24 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 17c1f637ded5..f2a5f47541d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = texlive-localmanager-git
pkgdesc = A shell and command-line utility to manage TeXLive on Arch Linux
pkgver = r84.bbd8488
- pkgrel = 2
+ pkgrel = 3
url = https://gitlab.archlinux.org/remy/texlive-localmanager.git
arch = any
license = GPL
@@ -20,10 +20,12 @@ pkgbase = texlive-localmanager-git
source = tllocalmgr-enhance.patch
source = tllocalmgr-fix-texlive-local-match.patch
source = tllocalmgr-pkgs-nicer-error.patch
+ source = tllocalmgr-mirror-opt.patch
sha256sums = SKIP
sha256sums = cd12f1927fa9d950855aab91b30039d0cbb328a8c7899382286d3ace16bb6a3b
sha256sums = 22222ff329919ee6a16ffd489b0213b14f8169d9daf6ef1a82aa5ab37538c236
sha256sums = a7698d0076f4e1a7ef401899c174ed9a290674a7e89e9c818ba078e17548c6e7
sha256sums = 1538426adada826f8faeed826e9be5f5610ade23ce0437535e39662294e6e108
+ sha256sums = d7064657f6336bed7be230fc05df800e6bdcee31d10c718b4b9b1b55f7f26c8a
pkgname = texlive-localmanager-git
diff --git a/PKGBUILD b/PKGBUILD
index de09b84d76bf..95bf6f0e425b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=texlive-localmanager-git
_pkgname="${pkgname%-git}"
pkgver=r84.bbd8488
-pkgrel=2
+pkgrel=3
pkgdesc='A shell and command-line utility to manage TeXLive on Arch Linux'
arch=('any')
url='https://gitlab.archlinux.org/remy/texlive-localmanager.git'
@@ -27,12 +27,14 @@ source=("${_pkgname}::git+https://gitlab.archlinux.org/remy/texlive-localmanager
'tllocalmgr-2021.patch'
'tllocalmgr-enhance.patch'
'tllocalmgr-fix-texlive-local-match.patch'
- 'tllocalmgr-pkgs-nicer-error.patch')
+ 'tllocalmgr-pkgs-nicer-error.patch'
+ 'tllocalmgr-mirror-opt.patch')
sha256sums=('SKIP'
'cd12f1927fa9d950855aab91b30039d0cbb328a8c7899382286d3ace16bb6a3b'
'22222ff329919ee6a16ffd489b0213b14f8169d9daf6ef1a82aa5ab37538c236'
'a7698d0076f4e1a7ef401899c174ed9a290674a7e89e9c818ba078e17548c6e7'
- '1538426adada826f8faeed826e9be5f5610ade23ce0437535e39662294e6e108')
+ '1538426adada826f8faeed826e9be5f5610ade23ce0437535e39662294e6e108'
+ 'd7064657f6336bed7be230fc05df800e6bdcee31d10c718b4b9b1b55f7f26c8a')
pkgver() {
cd "$_pkgname"
@@ -58,6 +60,9 @@ prepare() {
# make error on missing 'pkgs' file non-fatal, improve error msg
patch -p1 < "$srcdir/tllocalmgr-pkgs-nicer-error.patch"
+
+ # correctly pass --mirror option
+ patch -p1 < "$srcdir/tllocalmgr-mirror-opt.patch"
}
package() {
diff --git a/tllocalmgr-mirror-opt.patch b/tllocalmgr-mirror-opt.patch
new file mode 100644
index 000000000000..59876ed7a592
--- /dev/null
+++ b/tllocalmgr-mirror-opt.patch
@@ -0,0 +1,13 @@
+diff --git a/tllocalmgr b/tllocalmgr
+index b947ed2..8724243 100755
+--- a/tllocalmgr
++++ b/tllocalmgr
+@@ -34,7 +34,7 @@ GetOptions( $opts,
+ 'forceupdate',
+ 'localsearch', #TODO
+ 'location', #TODO ?
+- 'mirror',
++ 'mirror=s',
+ 'nocolor',
+ 'help|h',
+ 'version|v'