summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYaohan Chen2015-06-20 23:00:17 -0400
committerYaohan Chen2015-06-20 23:00:17 -0400
commit74b7af729187601ce10e8697ffb76ec666b77afe (patch)
tree3322e80a24264e64848a205de4d1bb2e0e99a362
downloadaur-74b7af729187601ce10e8697ffb76ec666b77afe.tar.gz
Initial import
-rw-r--r--.AURINFO20
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD57
-rw-r--r--air-generic-launcher.sh15
-rw-r--r--dofus.desktop.patch11
-rw-r--r--dofus.install16
-rw-r--r--dofus.patch11
-rw-r--r--transition.conf.patch20
8 files changed, 181 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..d4461ba89bec
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,20 @@
+pkgbase = dofus
+ pkgdesc = A manga inspired, Massively Multiplayer Online Role-playing Game (MMORPG) for Adobe AIR .
+ pkgver = 2.27
+ pkgrel = 1
+ url = http://www.dofus.com/
+ install = dofus.install
+ arch = i686
+ arch = x86_64
+ license = custom:Dofus License
+ depends = ankama-transition>=3.10.1-3
+ depends = adobe-air-sdk
+ source = http://dl.ak.ankama.com/games/linux/dofus-release-package.tar.gz
+ source = air-generic-launcher.sh
+ source = transition.conf.patch
+ source = dofus.patch
+ source = dofus.desktop.patch
+ backup = opt/ankama/dofus/transition.conf
+
+pkgname = dofus
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c3da7340e4b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = dofus
+ pkgdesc = A manga inspired, Massively Multiplayer Online Role-playing Game (MMORPG) for Adobe AIR .
+ pkgver = 2.27
+ pkgrel = 1
+ url = http://www.dofus.com/
+ install = dofus.install
+ arch = i686
+ arch = x86_64
+ license = custom:Dofus License
+ depends = ankama-transition>=3.10.1-3
+ depends = adobe-air-sdk
+ backup = opt/ankama/dofus/transition.conf
+ source = http://dl.ak.ankama.com/games/linux/dofus-release-package.tar.gz
+ source = air-generic-launcher.sh
+ source = transition.conf.patch
+ source = dofus.patch
+ source = dofus.desktop.patch
+ md5sums = 1fbc57d311bd113cd89780a42f9d2ced
+ md5sums = f179eaa5e6e6674b1853cf826fc33c3a
+ md5sums = ea9fb95c6027be5f0efb64fc7038f369
+ md5sums = f361c2d577f249d00581e73d5c4af175
+ md5sums = 06fe521608a2b4dd7766d7c6b48ae8ee
+ depends_i686 = gtk2
+ depends_i686 = alsa-lib
+ depends_i686 = alsa-plugins
+ depends_x86_64 = lib32-gtk2
+ depends_x86_64 = lib32-alsa-lib
+ depends_x86_64 = lib32-alsa-plugins
+
+pkgname = dofus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..48f8ba05c0de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Yaohan Chen <yaohan.chen@gmail.com>
+# Contributor: spider-mario <spidermario@free.fr>
+# Contributor: p2k <Patrick.Schneider@uni-ulm.de>
+# Contributor: Schtroumpfette <fpeterschmitt@voila.fr>
+
+pkgname=dofus
+pkgver=2.27
+pkgrel=1
+pkgdesc='A manga inspired, Massively Multiplayer Online Role-playing Game (MMORPG) for Adobe AIR .'
+arch=('i686' 'x86_64')
+url='http://www.dofus.com/'
+license=('custom:Dofus License')
+install='dofus.install'
+backup=('opt/ankama/dofus/transition.conf')
+depends=('ankama-transition>=3.10.1-3' 'adobe-air-sdk')
+depends_x86_64+=('lib32-gtk2' 'lib32-alsa-lib' 'lib32-alsa-plugins')
+depends_i686+=('gtk2' 'alsa-lib' 'alsa-plugins')
+
+source=('http://dl.ak.ankama.com/games/linux/dofus-release-package.tar.gz'
+ 'air-generic-launcher.sh'
+ 'transition.conf.patch'
+ 'dofus.patch'
+ 'dofus.desktop.patch')
+md5sums=('1fbc57d311bd113cd89780a42f9d2ced'
+ 'f179eaa5e6e6674b1853cf826fc33c3a'
+ 'ea9fb95c6027be5f0efb64fc7038f369'
+ 'f361c2d577f249d00581e73d5c4af175'
+ '06fe521608a2b4dd7766d7c6b48ae8ee')
+
+prepare() {
+ cd "$srcdir"
+ msg2 "Modifying transition configuration to use adl-based launchers"
+ patch -p0 < transition.conf.patch
+
+ #msg2 "Modifying launcher to avoid crash on start up"
+ #patch -p0 < dofus.patch
+}
+
+package() {
+ cd "$srcdir"
+ msg2 'Installing main applications...'
+ mv usr opt "$pkgdir/"
+
+ msg2 'Setting up game file permissions...'
+ _installdir="$pkgdir/opt/ankama/dofus"
+ chgrp -R games $_installdir
+ chmod -R g+w $_installdir
+
+ msg2 'Installing adl based launchers...'
+ install -Dm755 'air-generic-launcher.sh' "$_installdir/bin/air-generic-launcher.sh"
+ install -Dm755 'air-generic-launcher.sh' "$_installdir/share/reg/bin/air-generic-launcher.sh"
+
+ msg2 'Installing transition update file...'
+ ln -s '/opt/ankama/transition/' "$_installdir/transition"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/air-generic-launcher.sh b/air-generic-launcher.sh
new file mode 100644
index 000000000000..5271757d3b10
--- /dev/null
+++ b/air-generic-launcher.sh
@@ -0,0 +1,15 @@
+#!/bin/bash
+
+# This is a generic launcher script for AIR applications on Arch Linux
+
+SCRIPT_PATH=`readlink -f $0`
+SCRIPT_DIR=`dirname $SCRIPT_PATH`
+BASE_DIR=`readlink -f $SCRIPT_DIR/..`
+
+if [ "`uname -m`" == "x86_64" ]; then
+ export GTK_PATH=/usr/lib32/gtk-2.0
+ export G_FILENAME_ENCODING=UTF-8
+fi
+
+/opt/adobe-air-sdk/bin/adl -nodebug $BASE_DIR/share/META-INF/AIR/application.xml $BASE_DIR/share -- $*
+
diff --git a/dofus.desktop.patch b/dofus.desktop.patch
new file mode 100644
index 000000000000..5c67f1b92772
--- /dev/null
+++ b/dofus.desktop.patch
@@ -0,0 +1,11 @@
+--- usr/share/applications/dofus.desktop.orig 2014-08-21 11:30:29.655737368 -0400
++++ usr/share/applications/dofus.desktop 2014-08-21 11:31:24.428773971 -0400
+@@ -1,7 +1,7 @@
+ [Desktop Entry]
+ Encoding=UTF-8
+ Name=Dofus
+-Exec=/opt/ankama/transition/transition --configuration_file /opt/ankama/dofus/transition.conf --application-id=ankama-dofus-transition
++Exec=/usr/bin/transition --configuration_file /opt/ankama/dofus/transition.conf --application-id=ankama-dofus-transition
+ Icon=dofus
+ Terminal=false
+ Type=Application
diff --git a/dofus.install b/dofus.install
new file mode 100644
index 000000000000..0c797624ab76
--- /dev/null
+++ b/dofus.install
@@ -0,0 +1,16 @@
+post_install() {
+ chgrp -R games /opt/ankama/dofus
+ chmod -R g+w /opt/ankama/dofus
+ touch /opt/ankama/dofus/share/log4as.xml
+ chmod 666 /opt/ankama/dofus/share/log4as.xml
+ cat <<END
+The game files are installed under group "games". Please add your user
+to this group with "usermod -a -G games", otherwise you will need to
+enter your password when the game auto-updates.
+END
+}
+
+post_upgrade() {
+ post_install
+}
+
diff --git a/dofus.patch b/dofus.patch
new file mode 100644
index 000000000000..4c224556955b
--- /dev/null
+++ b/dofus.patch
@@ -0,0 +1,11 @@
+--- opt/ankama/dofus/dofus.orig 2014-08-21 11:30:54.415603233 -0400
++++ opt/ankama/dofus/dofus 2014-08-21 11:31:02.955556968 -0400
+@@ -14,7 +14,7 @@
+ exit 1
+ fi
+
+-TRANSITION="/opt/ankama/transition/transition"
++TRANSITION="/usr/bin/transition"
+ if [ ! -f $TRANSITION ];then
+ TRANSITION=$(which transition) || $(which ankama-transition) || error "Transition is not installed on your system" && exit 1
+ fi
diff --git a/transition.conf.patch b/transition.conf.patch
new file mode 100644
index 000000000000..35378ffb470f
--- /dev/null
+++ b/transition.conf.patch
@@ -0,0 +1,20 @@
+--- opt/ankama/dofus/transition.conf 2014-08-20 12:47:31.000000000 -0400
++++ opt/ankama/dofus/transition.conf 2014-08-20 14:10:41.622390819 -0400
+@@ -18,6 +18,16 @@
+ }
+
+
+-update.projects *= "transition"
+ update.projects *= "game"
+
++# Use the DBus service, which seems to work better, instead of sudo
++plugins.enable *= "dbusservice"
++
++# Use adl instead of Air binaries on Arch Linux
++bypass_air_installation = true
++
++dofus.reg.path = "${root}/share/reg/bin/air-generic-launcher.sh"
++
++launcher.command = """
++"${root}/bin/air-generic-launcher.sh" --lang=${i18n.lang} --update-server-port=${service_port} --updater_version=v2
++"""