summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-01-23 08:24:26 -0700
committerMark Wagie2023-01-23 08:24:26 -0700
commit7534d07a5a322cc3f690947d14f4c0bc28f1de29 (patch)
tree71fa9e571a720be7864bb2f67765f421205954a0
parentf4a9bda00dd4ffe6b781f82ed2f3fa0e265afc75 (diff)
downloadaur-7534d07a5a322cc3f690947d14f4c0bc28f1de29.tar.gz
update depenencies
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3125e3baf9f9..7af1fdb351b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = warpinator-git
pkgdesc = Share files across the LAN
- pkgver = 1.2.12.r0.gba80311
+ pkgver = 1.4.3.r2.g1889a48
pkgrel = 1
url = https://github.com/linuxmint/warpinator
arch = any
@@ -10,6 +10,8 @@ pkgbase = warpinator-git
makedepends = meson
makedepends = polkit
depends = gtk3
+ depends = libnm
+ depends = python-cairo
depends = python-cryptography
depends = python-gobject
depends = python-grpcio
@@ -18,6 +20,7 @@ pkgbase = warpinator-git
depends = python-protobuf
depends = python-pynacl
depends = python-setproctitle
+ depends = python-setuptools
depends = python-zeroconf
depends = python-xapp
depends = xapps
diff --git a/PKGBUILD b/PKGBUILD
index 3279446ee6e1..a978d092cc7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,16 @@
# Contributor: Kyle Laker <kyle@laker.email>
pkgname=warpinator-git
_desktop_id=org.x.Warpinator
-pkgver=1.2.12.r0.gba80311
+pkgver=1.4.3.r2.g1889a48
pkgrel=1
pkgdesc="Share files across the LAN"
arch=('any')
url="https://github.com/linuxmint/warpinator"
license=('GPL3')
-depends=('gtk3' 'python-cryptography' 'python-gobject' 'python-grpcio'
- 'python-netifaces' 'python-packaging' 'python-protobuf' 'python-pynacl'
- 'python-setproctitle' 'python-zeroconf' 'python-xapp' 'xapps')
+depends=('gtk3' 'libnm' 'python-cairo' 'python-cryptography' 'python-gobject'
+ 'python-grpcio' 'python-netifaces' 'python-packaging' 'python-protobuf'
+ 'python-pynacl' 'python-setproctitle' 'python-setuptools' 'python-zeroconf'
+ 'python-xapp' 'xapps')
makedepends=('git' 'meson' 'polkit')
checkdepends=('appstream-glib')
optdepends=('ufw: Configure firewall rules')
@@ -21,18 +22,15 @@ sha256sums=('SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags --exclude master* | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
cd "$srcdir/${pkgname%-git}"
# Fix hard-coded libexec dir
- sed -i 's/libexec/lib/g' \
- "bin/${pkgname%-git}.in" \
- "data/org.x.${pkgname%-git}.policy.in.in" \
- install-scripts/download_zeroconf.py
- sed -i 's/@libexecdir@/@libdir@/g' src/config.py.in
+ find . -type f -exec sed -i 's/libexec/lib/g' {} \;
+ find . -type f -exec sed -i 's/@libexecdir@/@libdir@/g' {} \;
}
build() {