summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillbelr2019-07-27 17:11:43 -0400
committerwillbelr2019-07-27 17:11:43 -0400
commit7581e381e91c02760efa300de3a146aac63cd09f (patch)
treed476ef257d85042312bd1e6a99cb16d77cb29435
downloadaur-7581e381e91c02760efa300de3a146aac63cd09f.tar.gz
Initial upload
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD26
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..96b1a19e5e90
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = retrolink-git
+ pkgdesc = Seamless integration of frontend and emulators through gamepad hotkeys
+ pkgver = 0
+ pkgrel = 1
+ url = https://gitlab.com/william.belanger/retrolink
+ arch = any
+ license = GPL3
+ depends = python
+ depends = python-setuptools
+ depends = python-pyqt5
+ depends = python-evdev
+ depends = xterm
+ provides = retrolink
+ conflicts = retrolink
+ source = git+https://gitlab.com/william.belanger/retrolink.git
+ md5sums = SKIP
+
+pkgname = retrolink-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..136d53a2ea37
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: William Belanger <echo d2lsbGlhbS5iZWxyQGdtYWlsLmNvbQ== | base64 -d>
+
+pkgname=retrolink-git
+pkgver=0
+pkgrel=1
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+pkgdesc="Seamless integration of frontend and emulators through gamepad hotkeys"
+url="https://gitlab.com/william.belanger/${pkgname%-git}"
+arch=("any")
+license=("GPL3")
+depends=("python" "python-setuptools" "python-pyqt5" "python-evdev" "xterm")
+source=("git+https://gitlab.com/william.belanger/${pkgname%-git}.git")
+md5sums=("SKIP")
+
+pkgver()
+{
+ cd "${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package()
+{
+ cd "${pkgname%-git}"
+ python setup.py install --optimize="1" --root="$pkgdir"
+}