summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Haag2020-04-16 01:40:32 +0200
committerChristoph Haag2020-04-16 01:41:41 +0200
commit7589e8bad6f5162303cb261e8b2ecb286d2ebece (patch)
tree1da1ee1fe0b1ac2f655fac8a8476d751dbaffdbb
downloadaur-7589e8bad6f5162303cb261e8b2ecb286d2ebece.tar.gz
initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD46
-rw-r--r--kwinft.install8
3 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c2654a4925ca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = kwinft-git
+ pkgdesc = drop-in replacement for KWin with additional libwayland wrapping Qt/C++ library Wrapland
+ pkgver = 5.18.0.beta.0.r7.g81fd1c3e7
+ pkgrel = 1
+ url = https://gitlab.com/kwinft/kwinft
+ install = kwinft.install
+ arch = x86_64
+ license = LGPL
+ makedepends = extra-cmake-modules
+ makedepends = qt5-tools
+ makedepends = kdoctools
+ depends = kscreenlocker-git
+ depends = xcb-util-cursor
+ depends = plasma-framework
+ depends = kcmutils
+ depends = breeze
+ depends = kinit
+ depends = qt5-sensors
+ depends = qt5-script
+ depends = wrapland
+ optdepends = qt5-virtualkeyboard: virtual keyboard support for kwin-wayland
+ provides = kwin
+ conflicts = kwin
+ source = kwin::git+https://gitlab.com/kwinft/kwinft.git
+ sha256sums = SKIP
+
+pkgname = kwinft-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12e895663aab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Christoph Haag <christoph.haag@collabora.com>
+# Author: Roman Gilg <subdiff@gmail.com>
+# Contributor: Antonio Rojas <arojas@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+
+_pkgname=kwin
+pkgname=kwinft-git
+pkgver=5.18.0.beta.0.r7.g81fd1c3e7
+pkgrel=1
+pkgdesc='drop-in replacement for KWin with additional libwayland wrapping Qt/C++ library Wrapland'
+arch=(x86_64)
+url="https://gitlab.com/kwinft/kwinft"
+license=(LGPL)
+#Depends on kscreenlocker 5.19 API
+depends=(kscreenlocker-git xcb-util-cursor plasma-framework kcmutils breeze kinit qt5-sensors qt5-script wrapland)
+makedepends=(extra-cmake-modules qt5-tools kdoctools)
+optdepends=('qt5-virtualkeyboard: virtual keyboard support for kwin-wayland')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_pkgname::git+https://gitlab.com/kwinft/kwinft.git")
+sha256sums=('SKIP')
+install=kwinft.install
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/^kwinft\@//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ mkdir -p "$srcdir"/build
+}
+
+build() {
+ cd "$srcdir"/build
+ cmake "$srcdir"/$_pkgname \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_INSTALL_LIBEXECDIR=lib \
+ -DBUILD_TESTING=OFF
+ make
+}
+
+package() {
+ cd "$srcdir"/build
+ make DESTDIR="$pkgdir" install
+}
diff --git a/kwinft.install b/kwinft.install
new file mode 100644
index 000000000000..5d249b2f744e
--- /dev/null
+++ b/kwinft.install
@@ -0,0 +1,8 @@
+post_install() {
+# this is executed by make install, but doesn't work since setcap can only be run as root
+ setcap CAP_SYS_NICE=+ep /usr/bin/kwin_wayland
+}
+
+post_upgrade() {
+ post_install
+}