summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302019-09-11 20:56:51 +0200
committerM0Rf302019-09-11 20:56:51 +0200
commit75a05e8e5c5be838948dccc00f7f1ad211852303 (patch)
treebee1f8a99aee85039aec368791df7563e3c6d78a
parent6b17920e4795cc98d189441c59ba91f0c2deebf3 (diff)
downloadaur-75a05e8e5c5be838948dccc00f7f1ad211852303.tar.gz
pyload-git: reverted to stable branch
-rw-r--r--.SRCINFO49
-rw-r--r--PKGBUILD71
-rw-r--r--pyLoadCli3
-rw-r--r--pyLoadCore3
-rw-r--r--pyLoadGui3
-rw-r--r--pyload-gui.desktop19
-rw-r--r--pyload-gui.pngbin0 -> 8093 bytes
-rw-r--r--pyload.conf65
-rw-r--r--pyload.desktop19
-rw-r--r--pyload.service4
-rw-r--r--pyload.svg107
11 files changed, 304 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6b2e73c75304..44e2ce26da5e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,31 +1,46 @@
pkgbase = pyload-git
- pkgdesc = Downloadtool for One-Click-Hoster written in python. Latest devel branch
- pkgver = v0.4.9.r4782.gd686d625b
- pkgrel = 2
+ pkgdesc = Downloadtool for One-Click-Hoster written in python. Latest stable branch
+ pkgver = v0.4.9.r4442.g9f346c75e
+ pkgrel = 1
url = https://github.com/pyload/pyload
+ install = pyload-git.install
arch = any
license = GPL
makedepends = git
- makedepends = python-jinja
- makedepends = python-setuptools
- depends = python
- depends = python-cheroot
- depends = python-cryptography
- depends = python-flask
- depends = python-flask-babel
- depends = python-filetype
- depends = python-flask-themes2
- depends = python-pycurl
- depends = python-requests-html
- depends = python-semver
+ depends = python2
+ depends = python2-crypto
+ depends = python2-pycurl
+ depends = tesseract
+ depends = python2-imaging
+ depends = python2-pyopenssl
+ optdepends = python2-pyqt: Gui
+ optdepends = python2-flup: for additional webservers
+ optdepends = python2-notify: Notifications for GUI
+ optdepends = js60: ClickNLoad
provides = pyload
conflicts = pyload
conflicts = pyload-hg
backup = var/lib/pyload/pyload.conf
- source = pyload-git::git+https://github.com/pyload/pyload.git
+ source = pyload::git+https://github.com/pyload/pyload.git#branch=stable
+ source = http://bitbucket.org/ranan/pyload-dist/raw/bf705af8f412/debian/pyload/usr/share/applications/pyload-gui.desktop
+ source = http://bitbucket.org/ranan/pyload-dist/raw/bf705af8f412/debian/pyload/usr/share/applications/pyload.desktop
+ source = http://bitbucket.org/ranan/pyload-dist/raw/bf705af8f412/debian/pyload/usr/share/pixmaps/pyload-gui.png
+ source = http://bitbucket.org/ranan/pyload-dist/raw/bf705af8f412/debian/pyload/usr/share/pixmaps/pyload.svg
source = pyload.service
+ source = pyload.conf
+ source = pyLoadCore
+ source = pyLoadCli
+ source = pyLoadGui
md5sums = SKIP
- md5sums = 75069bddcec3ee630d2abea02ffef0b4
+ md5sums = b96a4e5091463b3b7fd79208623f1a3a
+ md5sums = c67462993d27d5884677dd6e8a8a17d2
+ md5sums = 73fcec930d25a49e1b99576069d88bd5
+ md5sums = 649d5af94101655d37fe50e7b127d1b6
+ md5sums = 454e974b11ab31533423f336c3a182f2
+ md5sums = 32b00d50be868c165930c592b99730a9
+ md5sums = 6d764666ec89ce218cd00164e73e0989
+ md5sums = 6fc2f343d2f324a66745524bbab93e5c
+ md5sums = 806a22a74e8331dffcb8538182e4df2c
pkgname = pyload-git
diff --git a/PKGBUILD b/PKGBUILD
index 2fb1d254695b..c5d04a62436c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,76 @@
# Maintainer: robertfoster
-pkgname='pyload-git'
-pkgver=v0.4.9.r4782.gd686d625b
-pkgrel=2
-pkgdesc="Downloadtool for One-Click-Hoster written in python. Latest devel branch"
+pkgname=pyload-git
+pkgver=v0.4.9.r4442.g9f346c75e
+pkgrel=1
+pkgdesc="Downloadtool for One-Click-Hoster written in python. Latest stable branch"
url="https://github.com/pyload/pyload"
license=('GPL')
arch=('any')
provides=('pyload')
conflicts=('pyload' 'pyload-hg')
backup=('var/lib/pyload/pyload.conf')
-depends=('python' 'python-cheroot' 'python-cryptography' 'python-flask' 'python-flask-babel' 'python-filetype' 'python-flask-themes2' 'python-pycurl' 'python-requests-html' 'python-semver')
-makedepends=('git' 'python-jinja' 'python-setuptools')
-#install='pyload-git.install'
+depends=('python2' 'python2-crypto' 'python2-pycurl' 'tesseract'
+'python2-imaging' 'python2-pyopenssl')
+optdepends=('python2-pyqt: Gui'
+ 'python2-flup: for additional webservers'
+ 'python2-notify: Notifications for GUI'
+'js60: ClickNLoad')
+makedepends=('git')
+install='pyload-git.install'
-source=("$pkgname::git+https://github.com/pyload/pyload.git"
-'pyload.service')
+source=('pyload::git+https://github.com/pyload/pyload.git#branch=stable'
+ 'http://bitbucket.org/ranan/pyload-dist/raw/bf705af8f412/debian/pyload/usr/share/applications/pyload-gui.desktop'
+ 'http://bitbucket.org/ranan/pyload-dist/raw/bf705af8f412/debian/pyload/usr/share/applications/pyload.desktop'
+ 'http://bitbucket.org/ranan/pyload-dist/raw/bf705af8f412/debian/pyload/usr/share/pixmaps/pyload-gui.png'
+ 'http://bitbucket.org/ranan/pyload-dist/raw/bf705af8f412/debian/pyload/usr/share/pixmaps/pyload.svg'
+'pyload.service' 'pyload.conf' 'pyLoadCore' 'pyLoadCli' 'pyLoadGui')
pkgver() {
- cd $srcdir/$pkgname
+ cd pyload
git describe --long --tags| sed -r 's/([^-]*-g)/r\1/;s/-/./g'
}
+prepare() {
+ cd ${srcdir}
+ sed -i 's_#!/usr/bin/env python$_#!/usr/bin/env python2_' pyload/pyLoad*.py
+}
+
build() {
- cd $srcdir/$pkgname
- python setup.py build
- python setup.py build_locale
+ python2 -O -m compileall ${srcdir}/pyload
}
package() {
- cd ${srcdir}/$pkgname
- python setup.py install --root=$pkgdir --install-data locale
+ cd ${srcdir}
+
+ install -d -m 755 ${pkgdir}/opt/pyload
+ cp -r pyload/* ${pkgdir}/opt/pyload
+
+ install -d -m 755 ${pkgdir}/usr/share/applications
+ install -D -m 644 pyload.desktop ${pkgdir}/usr/share/applications
+ install -D -m 644 pyload-gui.desktop ${pkgdir}/usr/share/applications
+
+ install -d -m 755 ${pkgdir}/usr/share/pixmaps
+ install -D -m 644 pyload.svg ${pkgdir}/usr/share/pixmaps
+ install -D -m 644 pyload-gui.png ${pkgdir}/usr/share/pixmaps
- # Temporary fix for some not found resources
- cp -r src/pyload/core/config $pkgdir/usr/lib/python3.7/site-packages/pyload/core
- cp -r src/pyload/core/network/xdcc $pkgdir/usr/lib/python3.7/site-packages/pyload/core/network
- cp -r src/pyload/locale $pkgdir/usr/lib/python3.7/site-packages/pyload/
+ install -d -m 755 ${pkgdir}/usr/bin
+ install -D -m 755 pyLoadCore ${pkgdir}/usr/bin/pyLoadCore
+ install -D -m 755 pyLoadCli ${pkgdir}/usr/bin/pyLoadCli
+ install -D -m 755 pyLoadGui ${pkgdir}/usr/bin/pyLoadGui
# Create PyLoad service
install -D -m 644 ${srcdir}/pyload.service ${pkgdir}/usr/lib/systemd/system/pyload.service
+ install -D -m 644 ${srcdir}/pyload.conf ${pkgdir}/var/lib/pyload/pyload.conf
}
md5sums=('SKIP'
-'75069bddcec3ee630d2abea02ffef0b4')
+ 'b96a4e5091463b3b7fd79208623f1a3a'
+ 'c67462993d27d5884677dd6e8a8a17d2'
+ '73fcec930d25a49e1b99576069d88bd5'
+ '649d5af94101655d37fe50e7b127d1b6'
+ '454e974b11ab31533423f336c3a182f2'
+ '32b00d50be868c165930c592b99730a9'
+ '6d764666ec89ce218cd00164e73e0989'
+ '6fc2f343d2f324a66745524bbab93e5c'
+'806a22a74e8331dffcb8538182e4df2c')
diff --git a/pyLoadCli b/pyLoadCli
new file mode 100644
index 000000000000..d19f87597657
--- /dev/null
+++ b/pyLoadCli
@@ -0,0 +1,3 @@
+#!/bin/bash
+
+PYTHONPATH=/opt/pyload/module/lib python2 /opt/pyload/pyLoadCli.py "$@" \ No newline at end of file
diff --git a/pyLoadCore b/pyLoadCore
new file mode 100644
index 000000000000..cf7d20fc7f72
--- /dev/null
+++ b/pyLoadCore
@@ -0,0 +1,3 @@
+#!/bin/bash
+
+PYTHONPATH=/opt/pyload/module/lib python2 /opt/pyload/pyLoadCore.py "$@" \ No newline at end of file
diff --git a/pyLoadGui b/pyLoadGui
new file mode 100644
index 000000000000..93399f170176
--- /dev/null
+++ b/pyLoadGui
@@ -0,0 +1,3 @@
+#!/bin/bash
+
+PYTHONPATH=/opt/pyload/module/lib python2 /opt/pyload/pyLoadGui.py "$@" \ No newline at end of file
diff --git a/pyload-gui.desktop b/pyload-gui.desktop
new file mode 100644
index 000000000000..64e0e14e469f
--- /dev/null
+++ b/pyload-gui.desktop
@@ -0,0 +1,19 @@
+[Desktop Entry]
+Categories=Network;FileTransfer;Qt;
+Comment[de]=Graphical User Interface für pyLoad
+Comment=Graphical User Interface for pyLoad
+Exec=/usr/bin/pyLoadGui
+GenericName[de]=pyLoad GUI
+GenericName=pyLoad GUI
+Icon=pyload-gui
+MimeType=
+Name[de]=pyLoad GUI
+Name=pyLoad GUI
+Path=
+StartupNotify=false
+Terminal=false
+Type=Application
+X-DBUS-ServiceName=
+X-DBUS-StartupType=
+X-KDE-SubstituteUID=false
+X-KDE-Username=
diff --git a/pyload-gui.png b/pyload-gui.png
new file mode 100644
index 000000000000..5994b274d9ba
--- /dev/null
+++ b/pyload-gui.png
Binary files differ
diff --git a/pyload.conf b/pyload.conf
new file mode 100644
index 000000000000..d5e2a448d25e
--- /dev/null
+++ b/pyload.conf
@@ -0,0 +1,65 @@
+version: 1
+
+remote - "Remote":
+ int port : "Port" = 7227
+ ip listenaddr : "Adress" = 0.0.0.0
+ bool nolocalauth : "No authentication on local connections" = True
+ bool activated : "Activated" = True
+ssl - "SSL":
+ bool activated : "Activated"= False
+ file cert : "SSL Certificate" = ssl.crt
+ file key : "SSL Key" = ssl.key
+webinterface - "Webinterface":
+ bool activated : "Activated" = True
+ builtin;threaded;fastcgi;lightweight server : "Server" = builtin
+ bool https : "Use HTTPS" = False
+ ip host : "IP" = 0.0.0.0
+ int port : "Port" = 8001
+ str template : "Template" = default
+ str prefix: "Path Prefix" =
+log - "Log":
+ bool file_log : "File Log" = True
+ folder log_folder : "Folder" = Logs
+ int log_count : "Count" = 5
+ int log_size : "Size in kb" = 100
+ bool log_rotate : "Log Rotate" = True
+general - "General":
+ en;de;fr;it;es;nl;sv;ru;pl;cs;sr;pt_BR language : "Language" = en
+ folder download_folder : "Download Folder" = Downloads
+ bool debug_mode : "Debug Mode" = False
+ bool checksum : "Use Checksum" = False
+ int min_free_space : "Min Free Space (MB)" = 200
+ bool folder_per_package : "Create folder for each package" = True
+ int renice : "CPU Priority" = 0
+download - "Download":
+ int chunks : "Max connections for one download" = 3
+ int max_downloads : "Max Parallel Downloads" = 3
+ int max_speed : "Max Download Speed in kb/s" = -1
+ bool limit_speed : "Limit Download Speed" = False
+ str interface : "Download interface to bind (ip or Name)" = None
+ bool ipv6 : "Allow IPv6" = False
+ bool skip_existing : "Skip already existing files" = False
+permission - "Permissions":
+ bool change_user : "Change user of running process" = False
+ str user : "Username" = pyload
+ str folder : "Folder Permission mode" = 0755
+ bool change_file : "Change file mode of downloads" = False
+ str file : "Filemode for Downloads" = 0644
+ bool change_group : "Change group of running process" = False
+ str group : "Groupname" = pyload
+ bool change_dl : "Change Group and User of Downloads" = False
+reconnect - "Reconnect":
+ bool activated : "Use Reconnect" = False
+ str method : "Method" = None
+ time startTime : "Start" = 0:00
+ time endTime : "End" = 0:00
+downloadTime - "Download Time":
+ time start : "Start" = 0:00
+ time end : "End" = 0:00
+proxy - "Proxy":
+ str address : "Address" = "localhost"
+ int port : "Port" = 7070
+ http;socks4;socks5 type : "Protocol" = http
+ str username : "Username" = None
+ password password : "Password" = None
+ bool proxy : "Use Proxy" = False
diff --git a/pyload.desktop b/pyload.desktop
new file mode 100644
index 000000000000..16ec151df1f6
--- /dev/null
+++ b/pyload.desktop
@@ -0,0 +1,19 @@
+[Desktop Entry]
+Categories=Network;FileTransfer;
+Comment[de]=schlanker, schneller Open-Source Downloader
+Comment=fast, lightweight Open-Source Downloader
+Exec=/usr/bin/pyLoadCore
+GenericName[de]=pyLoad
+GenericName=pyLoad
+Icon=pyload
+MimeType=
+Name[de]=pyLoad Download Manager
+Name=pyLoad Download Manager
+Path=
+StartupNotify=false
+Terminal=true
+Type=Application
+X-DBUS-ServiceName=
+X-DBUS-StartupType=
+X-KDE-SubstituteUID=false
+X-KDE-Username=
diff --git a/pyload.service b/pyload.service
index 9f8fc0a0965e..4004c8f323a5 100644
--- a/pyload.service
+++ b/pyload.service
@@ -1,9 +1,9 @@
[Unit]
-Description=pyLoad Daemon
+Description=pyLoad Core
After=network.target
[Service]
-ExecStart=/usr/bin/pyload --daemon
+ExecStart=/usr/bin/pyLoadCore
User=pyload
Group=pyload
diff --git a/pyload.svg b/pyload.svg
new file mode 100644
index 000000000000..672a5af3390e
--- /dev/null
+++ b/pyload.svg
@@ -0,0 +1,107 @@
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<!-- Created with Inkscape (http://www.inkscape.org/) -->
+
+<svg
+ xmlns:dc="http://purl.org/dc/elements/1.1/"
+ xmlns:cc="http://creativecommons.org/ns#"
+ xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
+ xmlns:svg="http://www.w3.org/2000/svg"
+ xmlns="http://www.w3.org/2000/svg"
+ xmlns:xlink="http://www.w3.org/1999/xlink"
+ xmlns:sodipodi="http://sodipodi.sourceforge.net/DTD/sodipodi-0.dtd"
+ xmlns:inkscape="http://www.inkscape.org/namespaces/inkscape"
+ id="svg2"
+ version="1.1"
+ inkscape:version="0.48.1 r9760"
+ width="111"
+ height="111"
+ sodipodi:docname="logo.svg">
+ <metadata
+ id="metadata8">
+ <rdf:RDF>
+ <cc:Work
+ rdf:about="">
+ <dc:format>image/svg+xml</dc:format>
+ <dc:type
+ rdf:resource="http://purl.org/dc/dcmitype/StillImage" />
+ <dc:title />
+ </cc:Work>
+ </rdf:RDF>
+ </metadata>
+ <defs
+ id="defs6">
+ <linearGradient
+ id="linearGradient3815">
+ <stop
+ style="stop-color:#ffd642;stop-opacity:1;"
+ offset="0"
+ id="stop3817" />
+ <stop
+ style="stop-color:#ffe873;stop-opacity:1;"
+ offset="1"
+ id="stop3819" />
+ </linearGradient>
+ <linearGradient
+ id="linearGradient3773">
+ <stop
+ style="stop-color:#0062ae;stop-opacity:1;"
+ offset="0"
+ id="stop3775" />
+ <stop
+ style="stop-color:#4e8cbc;stop-opacity:1;"
+ offset="1"
+ id="stop3777" />
+ </linearGradient>
+ <linearGradient
+ inkscape:collect="always"
+ xlink:href="#linearGradient3773"
+ id="linearGradient3795"
+ x1="71.335106"
+ y1="77.345749"
+ x2="0.9232471"
+ y2="85.414894"
+ gradientUnits="userSpaceOnUse"
+ gradientTransform="translate(0,-58.255319)" />
+ <linearGradient
+ inkscape:collect="always"
+ xlink:href="#linearGradient3815"
+ id="linearGradient3845"
+ x1="68.186165"
+ y1="61.896278"
+ x2="32.517345"
+ y2="31.194151"
+ gradientUnits="userSpaceOnUse" />
+ </defs>
+ <sodipodi:namedview
+ pagecolor="#ffffff"
+ bordercolor="#666666"
+ borderopacity="1"
+ objecttolerance="10"
+ gridtolerance="10"
+ guidetolerance="10"
+ inkscape:pageopacity="0"
+ inkscape:pageshadow="2"
+ inkscape:window-width="959"
+ inkscape:window-height="1023"
+ id="namedview4"
+ showgrid="false"
+ inkscape:zoom="2.5405405"
+ inkscape:cx="63.638343"
+ inkscape:cy="54.211173"
+ inkscape:window-x="960"
+ inkscape:window-y="26"
+ inkscape:window-maximized="0"
+ inkscape:current-layer="svg2" />
+ <path
+ style="fill:url(#linearGradient3795);fill-opacity:1;stroke:#315788;stroke-width:1px;stroke-linecap:butt;stroke-linejoin:miter;stroke-opacity:1"
+ d="m 81.478723,1.7712768 c 0,4.765764 2.969157,23.0265952 -12.595745,23.0265952 l -23.420212,0 c -11.757126,0 -20.074469,5.29995 -20.074469,16.728724 l 0,11.808515 -9.840425,0 c -4.831138,0 -14.3670209,-3.17019 -14.3670209,-25.388303 0,-13.556823 3.5778243,-26.1755312 18.6968079,-26.1755312 z"
+ id="path2987"
+ inkscape:connector-curvature="0"
+ sodipodi:nodetypes="cccscccsc" />
+ <path
+ style="fill:url(#linearGradient3845);fill-opacity:1;fill-rule:evenodd;stroke:#cfb447;stroke-width:1px;stroke-linecap:butt;stroke-linejoin:miter;stroke-opacity:1"
+ d="m 75.671427,69.853532 c 0,7.377165 -10.701938,7.365555 -10.701938,-0.196312 0,-7.561867 10.701938,-7.180853 10.701938,0.196312 z M 56.090429,109.62234 28.930851,70.457447 l 0,-24.207447 c 0,-9.114114 2.68126,-16.236702 16.236702,-16.236702 l 21.747346,0 c 14.68592,0 19.23803,-11.824221 19.23803,-19.238032 l 0.0492,-9.0039892 8.26596,-0.196809 c 10.596551,0.208317 15.288621,6.948553 15.288621,25.9381532 0,19.925574 -5.50034,25.625677 -15.288621,25.625677 l -40.34575,0 0,5.904256 26.96277,0 0.368519,11.965305 z"
+ id="path3797"
+ inkscape:connector-curvature="0"
+ sodipodi:nodetypes="zzzccccccccssccccc" />
+</svg>