summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorevgfilim12019-08-18 23:41:12 +0500
committerevgfilim12019-08-18 23:41:12 +0500
commit75dd2d24555dcd3c2bfd454f1e133dc0eaf9dc9f (patch)
tree67f6a142a55098489bc82c2a46e1a6f855911d4e
parentd9ee470a3898274721053c15fda3453c3c00cfa3 (diff)
downloadaur-75dd2d24555dcd3c2bfd454f1e133dc0eaf9dc9f.tar.gz
New version: v2.3
Removed 'python-pip' dependency as this package can be installed without it using additional patch. Added more optional dependencies according to upstream repo and docs.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD29
-rw-r--r--no-pip.patch25
3 files changed, 56 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e9d737abeb32..b30b37a513f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-aiogram
pkgdesc = A pretty simple and fully asynchronous library for Telegram Bot API written in Python 3.7 with asyncio and aiohttp
- pkgver = 2.2
+ pkgver = 2.3
pkgrel = 1
url = https://github.com/aiogram/aiogram
arch = any
@@ -12,8 +12,14 @@ pkgbase = python-aiogram
depends = python-certifi>=2019.3.9
optdepends = python-uvloop: fast, drop-in replacement of the built-in asyncio event loop
optdepends = python-ujson: ultra fast JSON encoder and decoder written in pure C
- source = https://github.com/aiogram/aiogram/archive/v2.2.tar.gz
- sha256sums = 5bd01e03e6286c6b1e7c4fa37053441c2b576b8add221b8cbebd2a40e34c1937
+ optdepends = python-rapidjson: extremely fast C++ JSON parser and serialization library
+ optdepends = python-emoji: emojize and demojize support
+ optdepends = python-aioredis: Redis storage support
+ optdepends = python-aiohttp-socks: SOCKS4(a) and SOCKS5 proxy support
+ source = https://github.com/aiogram/aiogram/archive/v2.3.tar.gz
+ source = no-pip.patch
+ sha256sums = 20f509db24fdd54c700e54c9400c40cdf9ccce42716b690436787d1df8a14057
+ sha256sums = 6279e16e20acbae3e289cd0e5ba89db199753f35afa5201e3e8adbcd9c1653bb
pkgname = python-aiogram
diff --git a/PKGBUILD b/PKGBUILD
index 6dd3e27b9a9a..36699fd96b92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,34 @@
# Maintainer: Evgeniy Filimonov <evgfilim1@gmail.com>
pkgname='python-aiogram'
-pkgver=2.2
+pkgver=2.3
pkgrel=1
pkgdesc="A pretty simple and fully asynchronous library for Telegram Bot API written in Python 3.7 with asyncio and aiohttp"
arch=('any')
url="https://github.com/aiogram/aiogram"
license=('MIT')
depends=('python>=3.7' 'python-aiohttp>=3.5.4' 'python-babel>=2.6.0' 'python-certifi>=2019.3.9')
-makedepends=('python-setuptools')
-#makedepends=('python-setuptools' 'python-pip')
-optdepends=('python-uvloop: fast, drop-in replacement of the built-in asyncio event loop'
- 'python-ujson: ultra fast JSON encoder and decoder written in pure C')
-source=("https://github.com/aiogram/aiogram/archive/v${pkgver}.tar.gz")
-sha256sums=('5bd01e03e6286c6b1e7c4fa37053441c2b576b8add221b8cbebd2a40e34c1937')
+makedepends=(
+ 'python-setuptools'
+# 'python-pip'
+)
+optdepends=(
+ 'python-uvloop: fast, drop-in replacement of the built-in asyncio event loop'
+ 'python-ujson: ultra fast JSON encoder and decoder written in pure C'
+ 'python-rapidjson: extremely fast C++ JSON parser and serialization library'
+ 'python-emoji: emojize and demojize support'
+ 'python-aioredis: Redis storage support'
+ 'python-aiohttp-socks: SOCKS4(a) and SOCKS5 proxy support'
+# 'python-rethinkdb: RethinkDB storage support' # No such package yet
+)
+source=("https://github.com/aiogram/aiogram/archive/v${pkgver}.tar.gz"
+ "no-pip.patch")
+sha256sums=('20f509db24fdd54c700e54c9400c40cdf9ccce42716b690436787d1df8a14057'
+ '6279e16e20acbae3e289cd0e5ba89db199753f35afa5201e3e8adbcd9c1653bb')
+
+prepare() {
+ patch -u "$srcdir/aiogram-${pkgver}/setup.py" no-pip.patch
+}
build() {
cd "$srcdir/aiogram-${pkgver}"
diff --git a/no-pip.patch b/no-pip.patch
new file mode 100644
index 000000000000..9a3d93567bb2
--- /dev/null
+++ b/no-pip.patch
@@ -0,0 +1,25 @@
+--- setup.py 2019-08-17 01:00:02.000000000 +0500
++++ setup.py 2019-08-17 01:04:56.908355213 +0500
+@@ -5,11 +5,6 @@
+
+ from setuptools import find_packages, setup
+
+-try:
+- from pip.req import parse_requirements
+-except ImportError: # pip >= 10.0.0
+- from pip._internal.req import parse_requirements
+-
+ WORK_DIR = pathlib.Path(__file__).parent
+
+ # Check python version
+@@ -54,9 +49,7 @@
+
+ file = WORK_DIR / filename
+
+- install_reqs = parse_requirements(str(file), session='hack')
+- return [str(ir.req) for ir in install_reqs]
+-
++ return file.resolve().read_text().replace('\r', '').rstrip().split('\n')
+
+ setup(
+ name='aiogram',